Problem with Local Website "Error establishing a database connection"

I have a Problem with my DevKinsta site.
Yesterday it was working perfectly and I worked a lot on creating a new site.

Today I wanted to come back but I can’t reach the site anymore.
It says " Error establishing a database connection".

I tried a lot, but the error is still occurring.
I also checked the wp-config file but it looks fine to me.

Does someone has an idea how to fix this?
It would help me a lot.

Hi @MalteAn! Welcome to the Kinsta community!

I’m sorry to hear that you’re having difficulty accessing your site created with DevKinsta. I understand it is concerning to see this type of database connection issue especially after working a lot on a new site. We’re more than happy to assist you in resolving this issue!

The first thing we can try if you haven’t already is to fully shutdown and restart DevKinsta. This should shutdown and restart the DevKinsta related Docker containers. To do this you may close the DevKinsta window and then locate the DevKinsta related icon in the status bar of your computer. You may then right click that icon and choose to quit DevKinsta, and then choose to close and shut down the application.

After DevKinsta has been fully shut down please try to relaunch it. This should then restart the Docker containers related to the application. After this process please try visiting the site again to see if the issue is resolved.

If the issue persists we will want to ensure that the DevKinsta database related Docker container is running properly. To check this, please open the Docker Desktop application and ensure the “Containers” tab is selected. Next, look for a container named " kinsta/devkinsta_db:1.3.5" and confirm it is running. The icon should appear green, and the status should say “Running”.

Please let us know if restarting DevKinsta entirely resolves the issue, or if you are continuing to experience an issue. Also, please do confirm the status of the DevKinsta database Docker container if you are continuing to experience this issue after restarting DevKinsta.

We look forward to hearing back from you!