Site path restricted to C: in Windows issue

Q: Date/Time this occurred (Provide your time zone also)
This happens whenever, you tried to change the site path.

Q: DevKinsta Version
latest - 2.7.0

Q: OS Version
Windows 64-bit

Q: Docker Desktop Version

Q: Were any error codes or messages observed? If so, what were they?
Just keeps failing when trying to change site path - see image

Q: Detailed Description of the Problem
I’m trying to change my SitePath but as you can see, there seems to be a strange forward slash at the end of the default install site path. Anyway changing is impossible and Kevin asked that I open a bug report


Thanks for opening this @dgilfillan!
Can you first try this for me:

  1. Open your config.json. It should be somewhere like C:\Users\USERNAME\AppData\Roaming\DevKinsta
  2. Find the projectPath and change it to match this format if it doesn’t already
  3. Close and reopen DevKinsta then try to change the Site path within DevKinsta again.

If it fails again, please private message your main.log file to me. You can find that in C:\Users\USERNAME\AppData\Roaming\DevKinsta\logs

Thanks for sharing your main.log @dgilfillan!
I’m seeing this error, which is important: user declined directory sharing
Usually you get a popup from Windows/Docker asking for access to directories. I’m assuming you aren’t seeing those. I’m also assuming you’re using Hyper-V instead of WSL2.

Can you try opening Docker Desktop and adding your destination directory to “File Sharing?” Here’s how you do that:

  1. Go to the Docker Desktop setting page

  2. Add the new target directory here so that Docker has permission to move files there.

Now try moving DevKinsta to your new directory. Does it still fail? If so please send me your main.log again.
Thank you!

Hey Kevin, that’s resolved it now. Thank you so much! Great job!

I can also confirm I am able to move the DevKinsta Sitepath to another Drive. In my case I’ve moved it to my D Drive.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.