Unable to login to new install / email recovery not working

Hi, I’ve created a new (default) WordPress install with DevKinsta (on a Windows 10 environment). It creates a site I can browse, but when I go to login to WP Admin immediately after it is created, WP Admin says " Error : The password you entered for the username {username here} is incorrect".
I was copying and pasting it - it wasn’t incorrect, but to be sure, I typed it in manually. No luck. I deleted the WordPress install and created it again. Again it tells me the password is incorrect on the new install. I have viewed it to ensure there isn’t an issue with the copy/paste … no incorrect characters, no extra spaces, and as I say, also typed it manually.

I then tried to use the password reset tool - unsure of what email address it would send to, I imagined it would send the email to the email tab in the DevKinsta console - nothing arrived.
I checked the database details, and tried manually updating the user account with my own email address to see if that made any difference, also no luck.
I’ve also tried logging in with the email address that was in the database as the username. No luck.

So I’m unable to login to the WP instance I just created, and unable to do a password reset.
Any ideas what the issue could be / how I can get in to WP Admin?

1 Like

Hi Adam, welcome to the DevKinsta forums!

I’m sorry you’re having some trouble with creating a site.

Any emails sent by WordPress should end up in the email tab within DevKinsta, no emails are ever actually sent. If it’s not ending up there then an email wasn’t being generated.

Was this a fresh install or was it a clone from an existing MyKinsta site?

Hi Jeff, thanks!
It was a fresh install, and I’ve deleted it and started fresh a few times.
In terms of “then an email wasn’t being generated” … I can only tell you that I used the standard WordPress Admin password reset, and it was telling me on screen that an email had been sent.


Hi @adco. Try checking the Email Inbox on DevKinsta to see if it’s been sent there.

Hi Michael, you’ll see in my original post that I have already done that. I am not receiving the password reset emails to the DevKinsta mail tab. There are two issues raised in that original post, so there seems to be something broader going on.

1 Like

Hi @adco . Oh, I see that now. I’m sorry I missed that earlier. I think you may be right there may be a broader issue going on. Could you try re-installing DevKinsta and Docker and see if that helps? I also often like to test on my internal DevKinsta with a super simple password like 8 a’s to ensure I get it right every time (only local of course).

With the release of DevKinsta 2.0, could you tell us if you’re still having this issue? You can download DevKinsta 2.0+ here. Thank you and apologies for the trouble here.

We haven’t heard back from you on this topic in a while. However, if you do need further assistance you can simply start a new forum thread. Thank you again for using DevKinsta. Let us know if you need further assistance! :wave: