WordPress Site setup failed Error DK0021

Hi, I was on my Lenovo Yoga Laptop Win 10 home Where dev kinsta were very slow, loading a page takes 20 sec normally which was very annoying. I was suggested to try it in Hyper-V environment.

Now I set up my dev kinsta on my workstation, 64GB of RAM, SSD, Win 10 pro. and now I am on Hyper-V environment on docker. but I am getting the error [WordPress Site setup failed DK0021]

I tried the solution of restarting the app but no effect, instead I reinstall the devkinsta, did nothing.

I searched for the solution and again tried another solution by deleting [C:\Users\username\AppData\Roaming\DevKinsta\installers] elements but it also did no magic.

Error is still there and the same. It is very frustrating now being developing the site, and I am stuck at the beginning for the last 1 week.

Your solution would be appreciated.

1 Like

Hi @ahmedwasiq89, thanks for reaching out!
Can you please private message your main.log file to me?

I will check what the exact error is.

These are 2 main log files, kindly check these if the error can be resolved.

main.old.log (1.1 MB)
main.log (51.3 KB)

Thank you @ahmedwasiq89, looking at your error error logs, it looks like you were able to import a site into DevKinsta, is that correct?

This is the error that I’m seeing that’s causing the site creation error:

[error] [ipcMainStep] Error in operation SITE_CREATION, step baseapp: Error: Encountered an error: Error: Command failed: curl https://wordpress.org/wordpress-6.0.2.zip -o "C:\Users\USERNAME\DevKinsta\wp\wordpress-6.0.2.zip"
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (35) schannel: next InitializeSecurityContext failed: Unknown error (0x80092012) - The revocation function was unable to check revocation for the certificate.

This error seems to happen due to your network:

That step is trying to download WordPress then unzip it into that folder. Could you also try manually adding/extracting the WordPress zip? That may allow DevKinsta to skip this step

Manually adding wordpress won’t help, still same error.

I successfully imported my kinsta site in Dev Environment, but if I create new site from manual backup it stucks on “Validating Backup file”. and after an hour it says “something bad happens”

I want to Import through my downloaded backup so I can recreate the database name and other testing before uploading it to kinsta again. so help me in this too.

The other error I am facing while creating a new site stuck on this error “WordPress site setup failed DK0021”

I want to clear that the only option that is working direct import from kinsta, the other all options not working, like Import from backup zip file. or creating new site.

Please check these screenshoots.

The DK0021 is due to that network error I mentioned when DevKinsta tries to use cURL to download WordPress. Something with your system or network is blocking the cURL request. If you cannot configure your network then you will need to add the WordPress files manually.

If you populate the ~/DevKinsta/wp/ folder with extracted WP installs, DevKinsta will not try to download those ZIP files and should move on to the next step.

That folder is supposed to look like this:

With each ZIP extracted:

You can see exacly where the WP download is failing in your main.log. Here are links to the files that need to be downloaded:

Please download and extract each WP version and make sure the folder names match what I have. After this, please try creating a site again and share your main.log files with me so I can see the new errors, if any.

Thank you, that works as charm, extracting same name in that folder works, this problem is solved.

Now please help in importing from backup zip file which is not working as mentioned in previous reply.


Perfect; can you try the backup zip import one more time. It will fail but please share the main.log files with me right after it fails.

I’ll need to look over them and perhaps share with our developers since it is such a new feature.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.