Unable to use DevKinsta

I have tried to pull one of my sites, and it keeps failing around 33%. The log indicates that it is attempting to download wordpress, but not succeeding.

I also tried to to create site from a backup and it says it cannot verify the backup.

DevKinsta does not see to be ready for general use if I cannot easily create my site.

Hi @Aporia

Can you specify which Company and Site this is related to, so we can investigate?

Best regards,

The site is cheeseclubhk

Hi @Aporia can you please send me a copy of your main.log file via DM? You can find it by clicking on the question mark icon at the bottom left corner of DevKinsta and then on Reveal log file in File Manager.
We’d like to give a look at it and help you find the culprit.


Thank you for providing the log @Aporia, we are looking into it

the log shows a rsync issue which can happen in different scenarios.
I would recommend to try again to import the site from the backup, being sure to empty the following folder first:

The log shows that the backup restore fails when replacing multiple .xls files that already exist in that folder (wpallimport/files/Dairies.xlsx…)

That is interesting about the wpallimport files.

Unfortunately, I do not have the folder, /var/folders/wx/kk6lf36d3hx_1m_1lktcfcgc0000gn/T/cheeseclubhk

I am also hitting an issue where DevKinsta will not start, hanging on Starting Docker. Docker is not starting at all. Starting Docker manually does not help.

I have reinstalled DevKinsta and it still hangs

Hello there :slight_smile:

That’s interesting indeed! I couldn’t see the /var/folders… subfolder/path either on my Linux computer.
Perhaps that was just a temporary folder that was created (and got removed right away) when the backup/zip was extracted during the import process.

Was there any specific error shown in DevKinsta when it won’t start (hanging on starting Docker)?
What if you check the recent/latest main.log file and see if you would see this in it?

[error] Error: connect ENOENT /var/run/docker.sock

If it’s there, please try the suggestion/solution as shown here and here , and see if that would help?

Also, do you have any other sites created before in your Docker’s containers? if not, perhaps try to uninstall it completely and re-install Docker and re-load DevKinsta and see if it can start it properly?

Once everything is running fine again (both DevKinsta and Docker), please try to import the site from the backup file again.
If it’s still not importing properly, I would suggest with an alternative/manual method as shown on our article/doc here.

Let us know how it goes.


Docker has started, but DevKinsta still says Starting Docker…
I see this over and over again in main.log:

[dockerClient/isReady] Check if Docker client is ready

Ok, it finally got past that and then failed on the message above and I was able to fix it with:

sudo ln -s “$HOME/.docker/run/docker.sock” /var/run/docker.sock

I am spinning again:

[2023-04-14 14:42:12.717] [info] [containerExec] Command ‘cd /www/kinsta/public/cheeseclubhk && wp --allow-root --skip-themes --skip-plugins core version’ on devkinsta_fpm finished with exit code 1
[2023-04-14 14:42:12.718] [info] [checkWpVersion] site’s current version D[31;1mError:[0m This does not seem to be a WordPress installation.
[2023-04-14 14:42:12.718] [info] [checkWpVersion] site’s stored version 6.2
[2023-04-14 14:42:12.718] [info] [checkWpVersion] containerExec response test false
[2023-04-14 14:42:12.754] [info] [containerExec] Command ‘cd public/cheeseclubhk && wp --allow-root --skip-themes --skip-plugins db size --size_format=b --url=http://cheeseclubhk.local:64278’ on devkinsta_fpm finished with exit code 1
[2023-04-14 14:42:12.755] [error] Error: [31;1mError:[0m This does not seem to be a WordPress installation.Pass --path=path/to/wordpress or run wp core download.
at file:///Applications/DevKinsta.app/Contents/Resources/app.asar/dist/renderer.prod.js:2:1081825
at tryCatch (file:///Applications/DevKinsta.app/Contents/Resources/app.asar/dist/renderer.prod.js:8:2557688)
at Generator. (file:///Applications/DevKinsta.app/Contents/Resources/app.asar/dist/renderer.prod.js:8:2560222)
at Generator.next (file:///Applications/DevKinsta.app/Contents/Resources/app.asar/dist/renderer.prod.js:8:2558463)
at asyncGeneratorStep (file:///Applications/DevKinsta.app/Contents/Resources/app.asar/dist/renderer.prod.js:8:2548376)
at _next (file:///Applications/DevKinsta.app/Contents/Resources/app.asar/dist/renderer.prod.js:8:2548675)
at process.processTicksAndRejections (node:internal/process/task_queues:96:5)
[2023-04-14 14:42:14.837] [info] [ProgressIndicator] { isFailed: false, isOpen: true }

I have managed to get into the container and can confirm that wp is not found:

/www/kinsta/public/cheeseclubhk # wp
/bin/sh: wp: not found

Thank you for your reply and update Darcy Christ! :slight_smile:

Ok, it finally got past that and then failed on the message above and I was able to fix it with:
sudo ln -s “$HOME/.docker/run/docker.sock” /var/run/docker.sock

Glad to hear that you were able to fix that Docker related issue with the same method/solution in the other threads I shared before! :+1:

Regarding that wp cli that’s not found . I assume you tried to execute it inside the docker’s container (devkinsta_fpm) - with something like this: docker exec -u www-data -it devkinsta_fpm bash ?

If that so, could you please try to run:

 whereis wp

if the WP CLI is installed, it should show with something like:
wp: /usr/local/bin/wp

And we should be able to load it with that full path as well like:

/usr/local/bin/wp --version

like as follow for example (that I ran on my Linux computer) :

By the way, have you also tried that alternative/manual method to import an external backup - as shown on our article/doc here and see if that will work fine?


So that did work. I realised I had gone into the devkinsta_nginx docker.

But why would the log say no wp?

I’m going to try to set it up from a backup

Same issue with trying to import the download. I did clean up old wpallimport files, but I am unable to produce a new download.

Heya there :slight_smile:
Thank you for your reply and updates (and I got your DM as well).

I can see the error in that main.log file you sent to me via DM (failed on MySQL dump) :

[2023-04-14 19:45:08.380] [warn] [dumpSiteDatabase] Some warnings from mysql: 6Connection to 35.220.XXX.XXX closed by remote host.
[2023-04-14 19:45:08.396] [error] Error - DK0029: MYSQL_DUMP_COMMON: Error (255): 6Connection to 35.220.XXX.XXX closed by remote host.

Looks like your site’s database is quite large (~4.5 GB) and that might be the reason of the failed on MySQL dump.

Could you please also try the step-by-step, with a manual import method of that downloadable backup file (.zip) as shown in our article/doc there and see if that works?


I have tried that as well, although I am unable to make another backup, which is 4.5GB, since before I cleared old wpallimport files, the backup was 10GB. So I guess I will have to wait a week

For the downloadable backup, you can open a support chat (from MyKinsta control panel) to reach out to our support team and ask them to reset that weekly limit, so you don’t have to wait a week :slight_smile:
After that you will be able to create a new downloadable backup again from your MyKinsta .

Once you’ve downloaded that new .zip backup file, you can try and follow those steps again to import it manually:

  1. Creating a site in DevKinsta
  2. Importing your content
  3. Importing your database
  4. Search and replace

hopefully that will work fine! :crossed_fingers:


Hi Agus,

I am still struggling with this, as my database is still too big (1.5GB). And after compressing it (162.MB), it runs out of memory.

I was able to adjust php settings in devkinsta_fpm, but unable to do it in devkinsta_adminer, since I cannot install a text editor

/var/www/html $ apk update
ERROR: Unable to lock database: Permission denied
ERROR: Failed to open apk database: Permission denied

I found some recipes for adjusting the dockerfile, but I am unable to see where they are or to edit them.

Hi Darcy,

I suspect it runs out of memory due to PHP memory_limit set in the devkinsta_adminer perhaps (by default it’s set to 128M as I can see mine).

If you would like to increase the PHP memory_limit in that devkinsta_adminer container, perhaps please try the following:

  1. Get into the devkinsta_adminer with root user:
    docker exec -u root -it devkinsta_adminer sh

  2. In that devkinsa_adminer container, run this command, to check the current PHP memory_limit (mine returned with 128M):
    php -r "echo ini_get('memory_limit').PHP_EOL;"

  3. Then please run this command:
    echo 'memory_limit = -1' >> /usr/local/etc/php/conf.d/docker-php-memory_limit.ini
    (that will create a new docker-php-memory_limit.ini file under that sub-folder /usr/local/etc/php/conf.d/ which contains the memory_limit set to -1 )

  4. You can check again:
    php -r "echo ini_get('memory_limit').PHP_EOL;"
    (it should return -1)

See if that will help to prevent such PHP memory_limit error when you try to re-import that large DB with Adminer ?

Another method I may suggest would be to use WP CLI instead of Adminer, to import that .sql database file, with the following steps :

  1. Copy (or put) the .sql file (that’s extracted from your .zip backup file) into this site’s sub-folder on your local computer:

  2. Get into devkinsta_fpm container with www-data user:
    docker exec -u www-data -it devkinsta_fpm bash

  3. Go to your site’s folder in that container:
    cd /www/kinsta/public/yoursitename
    (and you should see the .sql. file you just copied in step 1 above in this sub-folder):
    ls -la *.sql

  4. Reset/empty that site’s database with:
    wp db reset

  5. Import that .sql file with:
    wp db import the-db-filename.sql

Once the .sql has been imported successfully, then the next step you may want to do is to perform Search and Replace.