Import from Kinsta gives blank wordpress install


I’ve just installed DevKinsta but after login and importing the website it doesn’t give me the actual website but a blank wordpress install.

1 Like

Hi @Maxwell, welcome to DevKinsta!

Just to confirm, is it only doing this when you try importing a site? Is it showing you the WordPress setup page similar to this case?

If you create a blank new WordPress installation within DevKinsta, does it still cause a similar issue?

This is also happening to me. When I try to import my Kinsta site, it appears that all of my files download successfully, but when I try to launch the site, it is just a generic WP site.

My case is exactly the same. I will try to uninstall Docker and DevKinsta and see what happens with fresh installs.

I will try to do that as well. Kinsta don’t enable us as developers ways to export and import the website is terrible experience. they want to force us to buy aditional website slots, that’s bad decision.

I tried the same thing this gentleman did, and I still get a blank WP site after running an import.
What should I try next?

Can you both share your Operating System information? @anglican, Is that Windows 11? I’ve brought this thread to our developers’ attention and we’ll see if they have any other recommendations or need more information.

1 Like

Yes, it is Windows 11. :slight_smile:

To update you, I installed DevKinsta on a different machine last night and had the same issue when attempting to import my site from Kinsta.

Hi @anglican

Our dev team reproduced this in a unique scenario where some of the database tables were not imported into the DevKinsta site.
Would you be able to compare your site in MyKinsta’s database with the DevKinsta database and see if the tables are all present?

Also, if you could send your main.log file and site name (in MyKinsta) in a DM we can try to take a closer look into what could be happening.

This log file can be accessed from the Help and Support page in DevKinsta (click the question mark (?) icon in the left sidebar) under the Support forum heading.

Getting the same issue. I tried to import staging site using devkinsta, and I’m getting a basic setup of wordpress instead the exact copy of my staging site.

1 Like

I am having the same issue, can i send you the log, I need this asap since we are not able to export using kinsta with other plugins I need to implement some new stuff on the project i am working in it and that’s took more time than I have

As i can see on the folder, the structure is there but it’s probably something related to the db. Where can I find that main.log you mentioned.

Hi @Maxwell,

I’m sorry to hear about the trouble. I believe you’re right in thinking its a database issue.
The import process to DevKinsta first creates a database dump, then syncs it over along with your files.
This is “backup.sql” in your site directory for DevKinsta.

After the files and dump have been synced, an import starts, which should be logged along with any errors from that attempt.

There are two log files that could help, the main.log as well as the main.log.old (a rotated copy that may have the needed entries).
You can DM those to me and I’ll have a look, or get in touch with our devs to provide any missing details I may see from your trouble.
This is an issue that’s being looked into based on the details everyone has helped share, and we will hopefully have a solution soon.

The log files can be accessed from the Help and Support page in DevKinsta (click the question mark (?) icon in the left sidebar) under the Support forum heading.
On macOS you can also go to Help > Reveal log file in the DevKinsta application menu at the top of the screen.


Thanks mate. here it is.

main.log (Removed) (280.3 KB)
main.old.log (Removed) (1.1 MB)

You’re welcome. I’ll have a look through these to see what I can help pinpoint, and send an update as soon as possible.

I removed the log files to avoid any sensitive data being shared but have the copies.

Thank you!


Could you check to see if in the local copy of your site there are database tables, and whether they are blank or not.
You can do that by opening the site in DevKinsta and clicking Database Manager.

This opens Adminer which will list your tables on the first screen that opens. You can view the contents of individual tables by clicking SELECT in the left column next to each.

@mcarino Welcome! If you could check this as well, and DM me a copy of your main.log (and site name in MyKinsta) that could help as well.

We’re still working to see what causes this and trying to reproduce the behavior. Unfortunately its not clear at the moment as it can only be reproduced by removing the tables so far.

If the wp_options table is missing that would be the expected result from WordPress, as it thinks its not installed and is new.

No table under labme name database. the other ones i think are just standard

if that helps I have several times the download process stopped and I had to restart. My internet speed is pretty good so I don’t think it’s related to that.

Hello again @DavidG Thanks for the great support but I need to report this foward so is there any time frame for this to be solved?