All websites get connection refused status and URL contains port number

Q: Date/Time this occurred (Provide your time zone also)
A: 3 weeks ago. After updating Devkinsta and Docker. Timezone GMT+2

Q: DevKinsta Version
A: 2.10.0

Q: OS Version
A: MacOS 12.0.1

Q: Docker Desktop Version
A: 4.17.0

Q: Were any error codes or messages observed? If so, what were they?

Q: Detailed Description of the Problem

A: Since I updated DevKinsta (and Docker) I cannot visit any of my local websites anymore. Every website I visit I get ERR_CONNECTION_REFUSED. Tested in multiple browsers.

What strikes me is that since I did the update and I open a site from the Devkinsta panel I get the port number behind every site :57357. This was not the case before. I could just visit any .local domain directly.

Hey @robbertv , welcome to DevKinsta Community!
Can you please send me a copy of your main.log file via DM? You can find it by clicking on the question mark icon at the bottom left corner of DevKinsta and then on Reveal log file in File Manager.
We’d like to give a look at it and help you find the culprit.


Thank you for providing the requested log file @robbertv.
:thinking: Can you please try to create a new site and tell us if you are able to see it without issues?

Hi Alessandro,

Thanks for your quick response.

I created a new website and that works, but it also has the port number in the URL.

Regarding the ports, was DevKinsta recently updated?

Also, can you please open the application called Terminal and run a ping as in:

ping yoursite.local

replacing yoursite with one of the existing domain added in DevKinsta. Do you see a response similar to the following, or a timeout?

PING yoursite.local ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=0.096 ms
64 bytes from icmp_seq=1 ttl=64 time=0.129 ms
64 bytes from icmp_seq=2 ttl=64 time=0.164 ms

@Alessandro my team is experiencing the same issues.

I do see the similar output when running
ping yoursite.local

Looks like this was resolved by ensuring mykinsta accounts are using 2FA

Yes, I get the same output when pinging one of the earlier websites:

64 bytes from icmp_seq=0 ttl=64 time=0.112 ms
64 bytes from icmp_seq=1 ttl=64 time=0.160 ms
64 bytes from icmp_seq=2 ttl=64 time=0.164 ms
64 bytes from icmp_seq=3 ttl=64 time=0.234 ms
64 bytes from icmp_seq=4 ttl=64 time=0.309 ms

But I do not have a mykinsta account connected.

Hello @robbertv :wave:

Can you please try the following and see if this will help to solve that port related issue ?

  1. Open your DevKinsta, then click on the bottom left (blue) icon - to open the Settings page
  2. On that Settings page, scroll down and locate for the “Port selector” section.
  3. Un-check the " Auto-detect open ports "
  4. Put 80 to the HTTP field, and put 443 to the HTTPS field.
  5. Click the “Confirm” button

After that, please try to access your local site(s) once again and see if it’s showing properly (without any additional port 57357 behind the URL)?

Please let us know again with the results.


@Agus thanks it works. I can only not visit the websites with HTTPS. Is that usual?

1 Like

Hey @robbertv ,
give this a go:

  1. Open the app called Keychain Access on your mac, it is preinstalled
  2. Select the Login tab at the left, and the Certificates at the top
  3. Find your local sites’ SSL certificates and copy them
  4. Move to the System tab at the left, and then paste the certificates
  5. Restart your browser


1 Like

Hi Alessandro,

Super thanks for your quick reply again.

Followed your instructions and it works :slight_smile:

Many thanks and have a great day.

1 Like

We are glad to be of help!

Thanks, you too :+1:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.