Devkinsta suddenly failed today

Today dev kinsta started freezing on ‘Starting Docker’. I’m not aware of any changes that would have caused this. So I read that in Docker settings under ‘Advanced’ I should enable ‘Allow the default Docker socket to be used’.

Now DevKinsta will load and a show a preview of the theme but when I start site and attempt to view it in browser I get ‘ERR CONNECTION REFUSED’.

Update: I tried cloning the site and now the error is:

I was able to pull a WP environment hosted from Kinsta to my local which is fully functional (except for the certificate which I can address on my own). I just don’t understand why my original environment I was working on is now bricked.

Any thoughts on next steps for troubleshooting would be super appreciated.

Hi @Tyler_Hervey :wave:

Can you also enable the “Allow privileged port mapping” option, restart your computer and let us know if that helps?

If not, can you let us know what OS, OS version, and DevKinsta version you’re using?

Also if you can DM @Agus @Alessandro and myself @ZachE your main.log file?

Best regards,

Hi @ZachE thank you for your response.

‘Allow privileged mapping’ was enabled but still same error after restart. I just DM’d main.log.


Hey Tyler :wave:
If you go into DevKinsta settings, under the Port selector section, is the checkbox for “Auto-detect ports” enabled or disabled?


This is currently enabled:

Thank you, and for the site that is currently saying “Site stopped by DevKinsta”, what is the status reported inside the site page in DevKinsta under “Site Status”?

shows the site as running:

Do you get an error if you try to stop and restart?

no errors when stopping and starting, UI appears gray:

Also, I tried spinning up a new site from scratch and it is incorrectly determining it to be a ‘custom site’ even though I selected wordpress during setup:

-attachment redacted-

and subsequent error:

Hi Tyler!

Thanks for the logs, we’ll review this and get back to you soon!

1 Like

version info:
MacOS Monterey 12.6.3
and I installed the latest devkinsta for intel macs

Hi Tyler!

Thanks for the extra details! I’m on Ventura with M1 Pro Silicon so not sure if I can replicate properly, but will keep on it. So far I am seeing these errors. These are for the theme-troubleshooting-demo site:

[2023-10-24 10:48:44.861] [info]  [containerExec] Command 'wp --allow-root --skip-themes --skip-plugins core is-installed --path=/www/kinsta/public/theme-demo-troubleshooting' on devkinsta_fpm finished with exit code 1
[2023-10-24 10:48:47.395] [error] create thumbnail error: Error: Request failed with status code 403

That would indicate that WP CLI didn’t detect the theme-demo-troubleshooting site as WP, then it tried to take a thumbnail and got a 403 Forbidden

[2023-10-24 10:48:59.417] [error] [createThumbnail] Failed to create thumbnail on /Users/tylerhervey/DevKinsta/public/theme-demo-troubleshooting/d922dadb-70cc-43a3-b8fc-73aa52e27b6d.png, no more tries

I think that one is an extension of the previous error.

These are for the tmt-dfy-theme-01 site when checking the site email inboxes:

[2023-10-24 10:49:47.843] [error] Error: [31;1mError:[0m This does not seem to be a WordPress installation.Pass --path=`path/to/wordpress` or run `wp core download`.
          'An error of type E_ERROR was caused in line 1016 of the file /www/kinsta/public/tmt-dfy-theme-01/wp-content/plugins/custom-post-type-ui/inc/utility.php. Error message: Uncaught TypeError: in_array(): Argument #2 ($haystack) must be of type array, null given in /www/kinsta/public/tmt-dfy-theme-01/wp-content/plugins/custom-post-type-ui/inc/utility.php:1016\r\n' +

That one is part of a WordPress Fatal error further down in the main.log for the tmt-dfy-theme-01 site

You said you tried to create a new WP site instead of a custom or import site, but custom-post-type-ui plugin doesn’t come with stock WP, so that’s confusing to see that in the logs, or it’s not the most recent logs?

Do you happen to have the other log files, e.g. starting from here:

Also, can you provide screenshots of your site directories ls -lat /www/kinsta/public/theme-troubleshooting-demo/ and checksum tests (command and steps in Docker context below)

I don’t have one called tmt-dfy-theme-01 or theme-troubleshooting-demo so I used one that already existed called testsite so you’ll have to replace it in the commands

I think it will be easier if we ignore the first theme and just focus on the fresh install for troubleshooting. I noticed there are no files/directories in the new site. Do you think this is a permissions issue?

Hey @Tyler_Hervey , I agree that it would be better if we focus on the vanilla install you did. Can you please share the Nginx configuration for that site? Inside your DevKinsta folder, you should see a nginx_sites folder that contains a .conf file for each of the sites you have. Can you send the one for this new site via DM, please? If the forum blocks you for the file extension, please send it as .txt


Picking up from where @Alessandro and I left off. Inside of devkinsta_fpm terminal i was able to CD into the theme directory and create a txt file (sorry I have added and removed sites so the name is different):

Hi all, after reading this: WordPress Installation Folder Is Empty After Creating New Site

it seemed the docker containers were definitely the issue. Wish I could say specifically but I just deleted them all and now I can spin up sites no problem.

Thank you for your update Tyler!
Glad to hear that you could spin up sites without problem! :+1:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.