Astro static site failed deployment

Hello and thanks for your help in advance.

I am trying to deploy an Astro static site.
The site is deployed on Vercel, but on Kinsta (it is a copy named differently) the deployment won’t happen.
As I have followed the Astro doc I do not understand what is wrong.

Any idea?

here the error message
Updating files: 28% (30/106)Updating files: 29% (31/106)Updating files: 30% (32/106)Updating files: 31% (33/106)Updating files: 32% (34/106)Updating files: 33% (35/106)Updating files: 34%

(100/106)Updating files: 95% (101/106)Updating files: 96% (102/106)Updating files: 97% (103/106)Updating files: 98% (104/106)Updating files: 99% (105/106)Updating files: 100% (106/106)Updating files: 100% (106/106), done.

2HEAD is now at b21808f first commit

3> mcl-v1@0.0.1 build

4> astro build

5sh: 1: astro: not found

62023/11/14 15:45:54 Skipping step because a previous step failed

Hello @LenaEUGENE and welcome to Kinsta Community!

Please give it a try by changing your start command to:

npm install && npm run build


Thank you for your rapid answer.
However this did not work.
I have tried with pnpm (which is what I use) as welll, but no luck.
here a link to the github repo just for you. if it is something you have time to check.

Otherwise I will welcome any other ideas.

After looking at the deployment before the last, I see this error:

Error: dist directory does not exist.

It seems you need to select the right publish directory in your site settings. The publish directory is the directory containing the HTML files and assets for deployment. This can be changed in the Basic details of your site in MyKinsta.


Hi there @LenaEUGENE

I’ve just tried to deploy my Astro static test site and could deploy it just fine.

I used the following settings in MyKinsta → Static Sites → my static site name → Settings → Basic details → Edit details:

(Same values as what’s suggested in our public documentation Set Up a Static Site With Astro on Kinsta® )

My Astro static site I deployed is accessible and is showing the following contents just fine:

So you may want to try to set the same on your Astro static site’s settings in MyKinsta, and see if you can deploy it! :crossed_fingers:

Best regards,

@Agus and @Alessandro ,

Long story short : I chose a easier route as I needed the website online this morning.
I guess it had to do the the abscence of of the dist folder or the presence of an adapter for Vercel (but removing it broke the site). Anyway…
That said had no problem deploying your template website in a matter of minutes.

I will try, once more, using your services on a project that will be build with hosting on Kinsta in mind.

Thank you for your time :grinning:

Alright, please take your time @LenaEUGENE :+1: :smiley: and you’re always welcome!