Can't connect to database DK0033

Was attempting to setup DevKinsta earlier while at the same time I was having issues with SSL and DNS, at that time I got the DD0021 error and it did connect to database but install would not finish and I also could not delete the failed (40%) setup. I uninstalled DevKinsta, reinstalled (windows 10), SSL and DNS on this new site are all fixed now so tried DevKinsta again and stuck on DK0033 “Can’t connect to database”

Hi @cphollingdale . Welcome! Great to see you on here :slight_smile:
Does the issue still occur if you completely exit DevKinsta and Docker then relaunch both?
Could you also tell us if you’re able to access the Database Manager as well?

Just terminated the docker.exe and, closed DevKinsta and relaunched, same issue. And no the Database manager is unclickable.

Just did a full uninstall of Docker and DevKinsta, full reinstall, now it has created the MySQL database but failed on DK0029 “Can’t create mysql dump”.

Update: Gave it a retry this morning and it was able to download the remote site but now is stuck on “Updating host file”.

Thanks for working with us on this! If you were to exit DevKinsta, does it provide you the option to retry because it failed?

Yep, gives the option and doing the retry again now, still spinning about 5 minutes, must be something hanging it up. For giggles just retried running program as Administrator, no change.

Hi @cphollingdale.

Let me know if that helps.

I have antivirus disabled, have told windows to run both Docker Desktop and DevKinsta as Administrator (via compatibility mode tab) and added a commented out line in my host file just to make sure it wasn’t being used by some other process. Same issue, DevKinsta is still stuck on “Updating host file”.

Update: I uninstalled everything today, DevKinsta, Docker Desktop & uninstalled Antivirus. Deleted all folders containing any data related to DevKinsta and Docker Desktop.
Changed windows 10 permissions to allow EVERYTHING Full Control,
Gave everything in the Access Control List for the Host file every permission and ran DevKinsta as Administrator… same issue… this time everything else during the install went smoot and fast, no other hangups but still stuck on “Updating Host File”.
Is there any kind of error log DevKinsta produces I can check? Going to check windows event logs now.

Hi Chris,

Can you check permissions on C:\Windows\System32\drivers\etc and ensure that “Read Only” is not checked?

I couldn’t edit the file the first time without that. Also went as far as removing “Read Only” from the entire “ect” folder and applying changes to all files below. No change.

Hi @cphollingdale . Apologies for the delay here. Could you tell us the output of the following from the Terminal?
echo testsite1.local >> C:/Windows/System32/drivers/etc/hosts

Returned nothing, no error so the syntax was correct but had no output. Did you want me to run this while DevKinsta was running? I was suspecting maybe a local Bitnami Wordpress VM could have been causing an issue (maybe using the host file) so I uninstalled that, and went to reinstall DevKinsta but now it wont finish the install… going to blast through my system, remove all registry entries for Docker Desktop/DevKinsta and do a once over on all my Windows Services currently running just to make sure I don’t have anything else that could be messing with the Host file, I’ll re-install DevKinsta + Docker Desktop after that and run the command.

Cleaning up the old install and noticed all the Docker Desktop logs, figured I would toss them in here in case you guys wanna look.

com.docker.backend.exe.log (530.8 KB) com.docker.backend.log (262 Bytes) com.docker.proxy.exe.log (767.3 KB) Docker Desktop Installer.exe.log (3.1 KB) Docker Desktop.exe.log (8.3 KB) Docker.exe.log (3.4 KB) docker.log (46.4 KB) docker.out.log (10.1 KB) dockerd.log (118.6 KB)

Wild hair up my arse so started looking through the logs, found one error and it mentioned “hardcoded network configuration”… I run all Static I.P.s and DNS… Going to finish cleaning previous install, have set my network setting to DHCP/auto-config and will test again.

No change with DHCP, ran the echo command again and no output… still stuck on “Updating host file”.

Thanks for all the information! We’re taking a look at this and will provide an update shortly.

With the release of DevKinsta 2.0, could you tell us if you’re still having this issue? You can download DevKinsta 2.0+ here. Thank you and apologies for the trouble here.