Can't create mysql dump DK0029/Can't change php version to match

Q: Date/Time this occurred (Provide your time zone also)
Fri Feb 11 14:12 EST
Q: DevKinsta Version
Q: OS Version
Mac 11.4 M1
Q: Docker Desktop Version
Q: Were any error codes or messages observed? If so, what were they?
Q: Detailed Description of the Problem
Importing a site gives error “can’t create mysql dump dk0029”

I’ve tried setting the php version to match the site (7.4), but every time I change it in the Kinsta app from 8.1 to 7.4, it resets itself back to 8.1

1 Like

Hi Dave, welcome to DevKinsta!
Can you private message your main.log file to me? You can find it when you click “Reveal log file…” on the Help and Support Page. I can share the details of the error with our developers.

When you say you tried changing the PHP version, were you trying this within DevKinsta after the import failed? Any screenshots of what you are seeing would be appreciated! I haven’t been able to reproduce a DK0029 error yet but with enough data we can figure out what’s happening.

Hi Kevin, thanks for the reply! I’ll get the log file to you. In the meantime here’s a video showing what I mean about changing the php version. Not sure if I’m doing something wrong there, I’m not able to press save, and when I got back to it, the version reverts to the latest.

and here’s a screenshot of the error:

1 Like

Thank you for all of that @dave; very useful!
I see what you mean about the PHP Version selector. I’m actually not sure how that’s supposed to work there. The same selector exists on the sites once they are created and it definitely works there. I’ll share this with the Devs .

Your main.log file is pointing towards actual database errors. I checked your Staging database and received the same errors when attempting to view your tables containing _uap_. They all complain say the table “references invalid table(s) or column(s) or function(s) or definer/invoker of view lack rights to use them”

This error also shows in your php error logs so it seems it’s causing the Mysqldump to fail once it reaches DevKinsta.

The affected tables have no content in them and I don’t see any of your plugins using them. I would suggest backing up your Staging environment then deleting the three tables that are causing this issue then trying the site pull again. Please let me know if it still fails after dropping those tables.

Hey Kevin,

We deleted those tables as suggested and now the site can complete importing from Kinsta but…

When trying to actually open the site locally, now I get this error:

"Connection error. Visit the admin area for more details or open the config.php file and check the database information. Message: No such file or directory.

There has been a critical error on this website."

When I try to visit the admin area as it suggests, I get the same error. The only change I did was remove those 3 tables from the database. And those tables were orphaned, the plugin that used them is not installed on the site anymore and hasn’t been for a while.

Hi @alexnasla; do you get a similar error if you create a new blank WP site within DevKinsta?

If not, can you let me know what DB_HOST you have in your wp-config.php?

/** MySQL hostname */
define( 'DB_HOST'

Actually @alexnasla the wording on that looked strange and it isn’t actually coming from WordPress. It’s coming from the Supportboard plugin. Maybe try disabling that by renaming the plugin folder.

The config.php mentioned in that file is under the supportboard plugin directory. It looks like you need to update the database configuration there it match what you have in wp-config.php. Devkinsta can’t do that automatically.