Can't delete site

Q: Date/Time this occurred (Provide your time zone also)
1/18/21 - 1:13 MST

Q: DevKinsta Version
Version 1.0.1 (

Q: OS Version
MacOS 11.1

Q: Docker Desktop Version

Q: Were any error codes or messages observed? If so, what were they?
You didn’t grant permission for site deletion.

Q: Detailed Description of the Problem
New install
Pulled site from Kinsta
Get error: DK0022 can’t edit hosts file
Error code page says to delete and try again.
Not able to delete the site.

<!-- Please upload your DevKinsta logs which can be found at: [2021-01-18 12:38:08.580] [info] Using devkinsta-updates for auto update [2021-01-18 12:44:24.322] [info] Checking for update [2021-01-18 12:44:24.328] [info] Generated new staging user ID: 6485eecb-a86d-5e00-95a6-9be2e38c6d64 [2021-01-18 12:44:24.714] [info] Update for version 1.0.1 is not available (latest version: 1.0.1, downgrade is disallowed). [2021-01-18 13:12:53.047] [info] Using devkinsta-updates for auto update [2021-01-18 13:12:56.184] [info] Checking for update [2021-01-18 13:12:56.432] [info] Update for version 1.0.1 is not available (latest version: 1.0.1, downgrade is disallowed).

Hi there. Thanks for reporting! Do you receive any errors if you were to create another blank site? Are there any prompts that appear when attempting to delete a site?

Hey Michael!

When creating a site from “New WordPress Site” or “Custom Site” I get the same error and I am not able to delete the sites.

FYI, Our little buddy Local by Flywheel updates /etc/hosts with no problem. I clean out my hosts file just to see if there was some formatting something going on and still no luck

I’ve cleaned out the docker images, removing docker desktop and KinstDev and will install and try again.

Removing the docker desktop app and then reinstalling Kinsta dev did it. The three sites I created were there after launch and I was able to delete them. Oddly I m now getting the correct prompts for my system user password that I was not being prompted for before.

Could have been my specific setup.

Interesting. We’ll keep monitoring this if it occurs with other uses. I’m glad it works. Thanks again!

We haven’t detected any other reports of this issue but will reopen if it continues to occur for others.

If you do need further assistance you can simply start a new conversation here on DevKinsta. Let us know if you need further assistance! :wave: