DevKinsta cannot Create Site

Q: Date/Time this occurred (Provide your time zone also)
A: 4/7/2023 and 4/8/2023 multiple times

Q: DevKinsta Version
A: I downloaded it yesterday, so whatever the most recent version is. I cannot find a version number

Q: OS Version
A: Windows 10 Pro

Q: Docker Desktop Version
A: Docker Desktop 4.18.0 (104112) is currently the newest version available.

Q: Were any error codes or messages observed? If so, what were they?
A: “Something bad happened”

Q: Detailed Description of the Problem
A: I downloaded DevKinsta and selected Add site > Import from Kinsta. I chose my site and it gets stuck at 35%. After an extremely long time DevKinsta finally just said “Something bad happened.”
I have uninstalled and reinstalled DevKinsta – including deleting any DevKinsta-related files. Made sure Docker is on the newest version. Cleared out all Docker images/containers/volumes. And I have done all of this multiple times. I tried creating a site without pulling it from Kinsta and it works.

Here is the logs: main.log (180.5 KB)

I am having the same issue. Why is it trying to download WordPress when in fact this is a copy of a site.

Hello @LucyTurtle and welcome to DevKinsta community!
The log shows a rsync issue, DevKinsta hasn’t received a response within a minute, this might happen due to a connection issue, or for some reason, rsync hasn’t been able to transfer a data chunk in a minute.
If the error persists after trying again, I would recommend to import the site manually. You can access your site in MyKinsta, move to the Backups page, and request a downloadable backup. Once the backup is ready you can download a copy of your site as .zip folder and import it manually in DevKinsta.
You can follow this guide on how to import the .zip backup


Hi @Alessandro ,
I’m also having this issue. My site is a large site (but not crazy large - around 14Gb) but it’s getting stuck around the 1.4Gb mark each time I try to install it.
I’m new to Kinsta - if I download the site as a .zip file would I still be able to connect it to the live site for easy deployment?

Hi @mrbjjackson and welcome to DevKinsta Community!
Absolutely, even if you import a site as zip file from a downloadable backup, you will be able to push it to your staging site in Kinsta (and from there to live if that is what you want to do).
If you’d like us to give a look at the main.log file to see if there’s a specific error, feel free to send it as an attachment via DM :+1:


1 Like

Hi @mrbjjackson :wave:

My colleague, Alessandro, reviewed the main.log you sent to him and has asked for suggestion to our internal dev team last week. One of our internal dev team members suggested that you could try restarting your Docker and increasing its resources a bit on the settings page. If that doesn’t work, then please try to freeing up space (if you have little available), or resetting volumes and containers could help.
Hopefully that may help to solve the issue you’re experiencing :crossed_fingers:


Hi @Agus and @Alessandro,
Thanks for looking into this for me. I’ve tried what you suggested and it is still not working.
I have now tried:

  • Using two different internet connections (work and home). Both are normally completely reliable.
  • Increasing the Docker resources (I have everything turned up full and I’m running a Apple M1 Max with 1Tb hard drive so this should definitely not be the issue)
  • I have tried removing all the images, volumes and containers from Docker and then reinstalling several times.

Every time I try to install the site on DevKinsta the installation fails after a random amount of time. Sometimes it gives up after just a gigabyte or so, but normally around the 4Gb mark. This morning it told me I had downloaded 14.1Gb of the 15Gb I need to download to install the site! :weary:

I’m surprised that this is not an issue that others are having too. It doesn’t feel like 15Gb is an unreasonable site size to download.

Please let me know if you have any other suggestions.

Many thanks

Ben I see you created a different thread so we’ll continue there