Can't login to DevKinsta

Q: Date/Time this occurred (Provide your time zone also)
**A: Started after upgrading to latest DevKinsta.

Q: DevKinsta Version
**A: 2.9.0

Q: OS Version
A: macOS Monterey 12.6.1

Q: Docker Desktop Version
**A: 4.12.0

Q: Were any error codes or messages observed? If so, what were they?
**A None.

Q: Detailed Description of the Problem
**A: Trying to log into MyKinsta via DevKinsta to push/pull content and databases and getting an error that the email and password combination do not exist. However, can log into with same credentials just fine.

Hello @leroyig :wave:

Thank you for reporting this case.

I don’t have Mac machine here, so couldn’t test it with it , but am not quite sure and doubt if it’s due to the OS related issue.

Anyway, I’ve tested to replicate this on both my Linux and Windows machines (with the latest/upgraded version 2.9.0 of DevKinsta) but couldn’t reproduce the login issue to MyKinsta account on both machines.

Here are some screenshots examples I took from my Windows machine:

(I clicked Log in to MyKinsta)

(I entered my MyKinsta user account’s login credentials - NOTE for the screenshot above, I changed the email address to something else just for security reason, but I did log in with my valid MyKinsta user’s email)

(then I was prompted to enter the TOTP - as I enabled 2FA for that MyKinsta user account, and I put the 6 digits TOTP generated in my auth software on my mobile phone into that field and it accepted just fine).

(my DevKinsta showed it’s connected to my MyKinsta account there - I blurred the email/name details in this screenshot).

Based on the screenshot you sent before, it sounds like the login credentials were incorrect (and/or the email account might not be correct / not valid in MyKinsta account perhaps?).

When I tried to re-login from my DevKinsta to my MyKinsta account (tried with incorrect password and/or not valid email account, I got the same error as shown in your screenshot: Can't find user with this email/password ).

If you’re still able to login to your MyKinsta control panel just fine, can you please try to change/reset your password there:

  1. Login to
  2. On MyKinsta control panel, click on the top right/header (drop down menu) and choose “User Settings”
  3. On the My Account → Account settings page, click the “Change password” button
  4. It will prompt you (in modal/pop-up) to enter the current password and the new password .
    “Resetting your password will log you out of all sessions as soon as you press the button. Please log in again with your new password!”
  5. See if you can re-login to MyKinsta with that same email user account and its new password you just set.

After that, please try again from DevKinsta to login to your MyKinsta with that same email user account and that new password you just set in MyKinsta.


Howdy @Agus,

I knew if I mentioned that the issue wasn’t my login credentials, that someone would chime in that it’s my login credentials.

It’s not. In fact just today after the holiday break it did finally work (no credentials were changed between this posting and today).

Hi @leroyig :wave: Happy New Year!

Thank you for your reply and update.
That’s quite strange indeed that it did finally work by itself :thinking: (and no credentials were changed at all), and is still unclear (mystery) what might be causing the issue before :sweat_smile: and I couldn’t replicate the issue.
Glad to see it’s working for you now. Please feel free to report again if the issue is back :crossed_fingers: .