Can't proceed from downloading

Q: Date/Time this occurred (Provide your time zone also)
A: 4 day ago

Q: DevKinsta Version
A: 2.13.1 (

Q: OS Version
A: MacOS Ventura 13.3.1

Q: Docker Desktop Version
A: 4.27.2 (137060)

Q: Were any error codes or messages observed? If so, what were they?
A: No error code or message was displayed

Q: Detailed Description of the Problem
A: Can’t proceed from downloading.

I tried several sites but got the same result

The app crashed once while creating a site.
At that time, devkinsta stopped starting and I reinstalled it.
I deleted the devKinsta part of hosts, is that the problem?


[2024-02-26 09:01:52.022] [info]  [ProgressIndicator] { isFailed: false, isOpen: false }
[2024-02-26 09:01:52.033] [info]  [ProgressIndicator] { isFailed: false, isOpen: false }
[2024-02-26 09:01:52.054] [info]  [containerExec] Command 'mysql -u root -p****** -e "create database xxxx;"' on devkinsta_db finished with exit code 0
[2024-02-26 09:01:52.055] [info]  [pullSite] Start downloading site (with all steps)
[2024-02-26 09:01:52.055] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container
[2024-02-26 09:01:52.069] [info]  [ProgressIndicator] { isFailed: false, isOpen: false }
[2024-02-26 09:01:52.081] [info]  [ProgressIndicator] { isFailed: false, isOpen: false }
[2024-02-26 09:01:52.504] [info]  [containerExec] Command 'ssh xxxx@ -p 60076 -o "UserKnownHostsFile /dev/null" -o "StrictHostKeyChecking no" -o "PasswordAuthentication no" -o "ChallengeResponseAuthentication no" 'echo 1'' on devkinsta_fpm finished with exit code 0
[2024-02-26 09:01:52.504] [info]  [renewSshKey] SSH key is valid
[2024-02-26 09:01:52.505] [info]  [createMySqlDump] Create mysql dump
[2024-02-26 09:01:52.505] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container
[2024-02-26 09:01:52.792] [info]  [containerExec] Command 'ssh XXX@ -p 60076 -o "UserKnownHostsFile /dev/null" -o "StrictHostKeyChecking no" -o "PasswordAuthentication no" -o "ChallengeResponseAuthentication no" 'mysqldump  -h localhost -u xxxx -p****** xxxx > "/www/xxxx/public/backup.sql"'' on devkinsta_fpm finished with exit code 0
[2024-02-26 09:01:52.793] [info]  [deleteFile] Start deleting files: { paths: [ '/Users/xxxx/DevKinsta/public/xxxx/*' ] }
[2024-02-26 09:01:52.797] [info]  [downloadSite] Calculate remote folder size
[2024-02-26 09:01:52.797] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container
[2024-02-26 09:01:53.076] [info]  [containerExec] Command 'ssh xxxx@ -p 60076 -o "UserKnownHostsFile /dev/null" -o "StrictHostKeyChecking no" -o "PasswordAuthentication no" -o "ChallengeResponseAuthentication no" 'du -sb /www/xxxx/public'' on devkinsta_fpm finished with exit code 0
[2024-02-26 09:01:53.077] [info]  [downloadSite] Download files
[2024-02-26 09:01:53.077] [info]  [isWslMode] check if docker runs on wsl mode
[2024-02-26 09:01:53.494] [warn]  [terminalExec] Error: Warning: Permanently added '[]:60076' (ED25519) to the list of known hosts.
[2024-02-26 09:01:53.799] [info]  [ProgressIndicator] { isFailed: false, isOpen: true }
// Many same log

[2024-02-26 09:02:02.859] [info]  [ProgressIndicator] { isFailed: false, isOpen: true }
[2024-02-26 09:02:03.942] [info]  [containerExec] Command 'chown -R www-data:www-data /www/kinsta/public/XXX' on devkinsta_fpm finished with exit code 0
[2024-02-26 09:02:03.943] [info]  [importBackupToDb] Import db
[2024-02-26 09:02:03.943] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container
[2024-02-26 09:02:04.028] [info]  [containerExec] Command 'mysql -h devkinsta_db -u root -p****** XXX < "/www/kinsta/public/XXX/backup.sql"' on devkinsta_fpm finished with exit code 0
[2024-02-26 09:02:04.028] [info]  [importBackupToDb] Import db done, deleting dump
[2024-02-26 09:02:04.029] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container
[2024-02-26 09:02:04.057] [info]  [containerExec] Command 'rm -f /www/kinsta/public/XXX/backup.sql' on devkinsta_fpm finished with exit code 0
[2024-02-26 09:02:04.058] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container

Hi @Ituki_Yanagimachi :wave:

I’m sorry to hear you are having difficulty downloading your site to your DevKinsta app! I understand the significance of addressing this matter promptly, considering the potential impact it may have.

Additionally, could you please share the unfiltered main.log file for the relevant site with us through a private message? This will enable us to delve deeper into the recent logs and identify any issues causing the download process to appear stuck or stalled.

Your cooperation in providing this information is greatly appreciated.

Best regards,

I solved this. thank you.

how to

  1. i try “create site and custom setting”, but it didn’t work

  2. i kill devKinsta, and site delete

  3. create site and import Kinsta

Hi @Ituki_Yanagimachi

That’s great to hear and thank you for posting the steps that worked!

Kind regards