Can't use DevKinsta cause of docker no container issue

!I’m running on Win 10Home. after installation and restart (as system asked me to restart after installation) when i open devkinsta i got this error

then docker states it “Failed to start” , on hover over the bottom-left part and says no container.

I followed what was stated and i run this command:
docker run -d -p 80:80 docker/getting-started

but also got docker error in powershell:
docker: error during connect: This error may indicate that the docker daemon is not running.: Post http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.24/containers/create: open //./pipe/docker_engine: The system cannot find the file specified.
See ‘docker run --help’.

Steps done:

  1. Enabled WSL with this command:
    dism.exe /online /enable-feature /featurename:Microsoft-Windows-Subsystem-Linux /all /norestart

  2. Enabled Virtual Machine feature with this command:
    dism.exe /online /enable-feature /featurename:VirtualMachinePlatform /all /norestart
    Visualization is Enabled on my laptop

  3. Downloaded the Linux kernel update package.

I basically followed the steps here for manual process.

But only steps 1-4. when I run this command (from step 5):
wsl --set-default-version 2 I got this problem:
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

I can’t run devkinsta until I figure out this docker issue. Is there anything that I missed?

x64-bit, 8GB, i5

P.S I’m new to docker & just following the instructions from your documentation and getting some help on Youtube.

Hi @rhea ! Thanks for joining us here at DevKinsta! I’m happy to help.

Would you happen to have anything else running in the background that would prevent Docker from running normally? Perhaps any software like an antivirus or firewall running?

Hi @michael. Yes I have both Antivirus Kaspersky security cloud and Firewall running.

@rhea Thanks for checking! Would you mind disabling those and let me know if it helps?

Hi. I disabled both my antivirus and firewall but still the same.

After a bit of searching, I found that this appears to be a common issue among many Windows users with Docker.

It sounds like you’ve already done a few of these steps but there might be others on here that might help. Try this here. I’ll continue researching here too.

1 Like

Hey @rhea . I received additional feedback from the devs here to try uninstalling then reinstalling Docker. Your Docker is having trouble connecting to WSL.

1 Like

Hi @michael, thank you for the help. Now it’s working. I did follow some of the steps from the links you gave and here’s the steps that worked for me.

  1. I uncheck Windows Subsystem for Linux in Windows Features
  2. Uninstall Linux kernel update package
  3. Restart PC
  4. Manually install docker without the WSL2 enabled/checked in the first screen
  5. Check (or turn on) again the Windows Subsystem for Linux in Windows Features
  6. Re-install the Linux kernel update package
  7. Restart PC

Hope the steps above can help others who might be having the same issue as it worked for me.

Now the only problem is it won’t connect to the database. Error: DK0033

Thank you for providing the solution here for others!

Try the solution posted here and let me know if that works for you.

Thank you so much. Everything is working properly now.

1 Like