Dev Kinsta Stuck

I downloaded the new version of Dev Kinsta and am trying to start from scratch. I uninstalled the old version and removed all sites as they do not exist anymore. After doing this I downloaded the new version of DevKinsta and tried to open it. Now its stuck on configuring database root user and will not load any further than this. Can you please assist. Its been like this for about an hour now.


Still stuck there. Now for 2 hours and I have tried to restart everything

Hi Mike @mwalcott :wave:

Apologies for the delay in response to this! You mentioned that you removed the sites, though I wonder if that was only from DevKinsta. Would you be able to shut down DevKinsta, then remove the Docker containers and volumes. From there, restart Docker, then start DevKinsta, and let us know if you’re able to get through the database setup? You can then test it actually works by attempting an import of an existing MyKinsta Site within DevKinsta.

To reset Docker, you would start by opening Docker Desktop, going to Containers, selecting all containers via the top checkbox, then clicking Delete. Then do the same with Volumes, and restart Docker Desktop. If you have other Docker containers and Volumes for other purposes, then you can leave those be.

Best regards,

Ok I got that working now. Another issue though. I have multisite and pulled everything down from server. The main site works but the subdomain sites that I have are not working. Any thoughts here. If you need any info please let me know

Looks like we still have manually adjust the Hostfile. Will be automated in the future or will I need to always add this anytime I create a new subsite on the network?

Hello @mwalcott Mike :wave:

For the subdomain based WP multisite, you will need to always add the new sub-domain host in the hosts file each time you create that new subsite (subdomain) on your WP Admin network, as shown on our knowledge base here: How To Run a Multisite in DevKinsta With Subdomains