Can't Launch DevKinsta

I don’t usually use DevKinsta (I usually use Flywheel’s Local), but wanted to use it for something specific today. It has worked for me in the past.

Today, I launched DevKinsta, and it came up with an update available. So I download the update, close DevKinsta, and run the installer/updater.

I now cannot launch DevKinsta. When it starts up, it goes through the process to boot up Docker, and then gets to the “Configuring database root user…” step and does not go past that no matter how long I wait.

I have tried exiting out of DevKinta and Docker. I have tried rebooting. I have tried uninstalling and reinstalling devkinsta. None of this has worked.

Similar thing is happening to me. I’m getting the word “errors” in the bottom left and “retry” in bottom right. Clicking Retry does nothing. I’m pretty new to all this, so I have very little idea how to debug this.

Hello @akschoeck & @WPwithHeart and welcome to DevKinsta community!

Can you please specify what OS and DevKinsta version you are using?



Hi Alessandro, thanks for the reply! I am using Windows 10 Home and DevKinsta 2.9.0.

My issue has morphed back to the 404 Not found. The reason why I may have been getting the stalled error, etc may have been because I changed the config file based on another post here.

I had reverted back to original file and was able to load Kinsta, but with 404 not found for every single site. I don’t want to hijack this post. So, maybe I should start another?

I was having the same issue. Restarted, removed containers from docker etc. What fixed it for me was updating Docker Dekstop (didn’t see there was an update waiting). Then after that DevKinsta opened up nicely.

Hey @WP-Ensure welcome to DevKinsta community!
Thank you very much for sharing your solution, I am sure this might save some time to other users in the future :raised_hands:

1 Like