DevKinsta hangs in a variety of places

I’ve had DevKinsta installed for quite some time, and the containers have been running OK without issue. I had a need to actually connect to the DevKinsta GUI today (for the first time in months), and I haven’t been able to get it to start.

The strange thing is, it seems to be randomized in terms of how far into the startup process it gets. Sometimes it will hang at “Starting docker containers…”. Sometimes it will hang at “Updating docker containers…”. Once it asked for my password (to run /bin/bash, as I’m used to it doing), and then it got as far as “Creating root DB user”, and hung there.

I am running this on Ubuntu 22.04 using Docker Engine. I will upload a copy of the main.log file. There are no errors in it. It appears to always get hung up on a message such as:

[2024-03-22 11:46:17.092] [info]  [dockerUtil/getContainer] Get 'devkinsta_db' Docker container


[2024-03-22 11:51:58.757] [info]  [dockerUtil/isContainerExists] Check if 'devkinsta_mailhog' container exists

but is seemingly different each time. I’ve tried removing those containers, to no avail. But of course, now that I’ve removed the containers, I can’t actually run my store anymore, because the DevKinsta startup has only recreated some of them. At first it failed to create them all. The next time, it created devkinsta_nginx. Now I have that one plus devkinsta_fpm, but no db, adminer, or mailhog.

main.log (26.3 KB)

I should add that I’ve seen this behavior before - where it will hang on startup, prior to asking for the password - but in the past, every time I simply had to close DevKinsta once and restart, and then it would always work. Now I seem to be stuck and can’t progress, no matter how many times I try.

Hi @Shaun_Dishman! Welcome to the Kinsta community! Thank you for reaching out to us!

I’m sorry to hear that DevKinsta appears to be hanging at startup on your computer. I understand this type of experience can be frustrating. We’re here to help find the root cause of the problem, and resolve the issue.

I presume you have likely already tried this. But, does restarting your computer entirely help resolve the issue, or change the launch behavior?

I also see that you are running DevKinsta on Ubuntu 22.04. However, we would like to gather some additional information to better understand your current setup/configuration. Please provide the following information so we can better assist you:

  • DevKinsta Version
  • Docker Engine version

Having this information will better assist us in our investigation, and with attempting to replicate the issue.

We look forward to hearing back from you!


Yes, I tried restarting - no effect.

As for your other questions:

  1. DevKinsta Version: I was running 2.9.0-6037, but I just updated to the latest (2.13.2-8696), and the problem still occurred initially. However, with the newer interface, I do see information I didn’t see before. Now I get a DK0006 “Couldn’t download docker images” error, with a Retry button. Previously the loading screen just hung indefinitely, so that at least feels like a step forward. Additionally, when I clicked Retry several times, I was finally prompted for a password, and was able to get past the loading screen. So that is a success!

  2. Docker Engine Version: 25.0.5

Given that I’ve been able to get past this, I guess we can technically consider this resolved, but wanted to provide the info you requested in case you wanted to do more exploring.


Hi @Shaun_Dishman :wave:

Thank you for the update. We are happy to hear that the problem has been resolved. We hope that you will have a smooth experience using our local deployment tool going forward. However, if you encounter any issues, please do not hesitate to post here to seek for assistance. We are always here to help. :slightly_smiling_face: