DevKinsta stuck on DK00006 after reinstall


I am using an Intel Macbook Pro and I installed DevKinsta, got it working fine, tried changing the link to one of my sites and got an error that it could no longer load the Nginx certificate. The entire application was basically unusable (no way to cancel the process, no way to stop the site, nothing … which is a design flaw all on its own but I digress).

I tried restarting the application but kept getting stuck on “Couldn’t load docker images”, DK0006 error.

Anyway, I eventually decided to just uninstall and reinstall the application. Got stuck again on the DK0006 error, could see that one of the docker containers failed to run (same Nginx certificate error). Decided to uninstall the entire application and remove the docker containers, thinking it would rebuild them on install.

Obviously never happened.

So I am stuck again, on DK0006, and don’t know what to do. Can anyone help before I give up on this thing altogether?

Here is the log if it helps

Hi @MDU and welcome to Kinsta Community!

Can you please clarify if when opening Docker you do see the containers? If so, what is the error that they show about the certificate? Can you please share a screenshot?


Hey! No I don’t see them anymore because I deleted them. Which I probably shouldn’t have, I just assumed it would recreate them on reinstall but sadly I was wrong.

The error I got initially was this:

2023-07-19 10:47:51 nginx: [emerg] cannot load certificate "/www/kinsta/ssl/orb-tst.localhosthosthosthosthosthosthosthosthosthosthosthosthosthosthost.crt": BIO_new_file() failed (SSL: error:80000002:system library::No such file or directory:calling fopen(/www/kinsta/ssl/orb-tst.localhosthosthosthosthosthosthosthosthosthosthosthosthosthosthost.crt, r) error:10000080:BIO routines::no such file)

If you haven’t imported/worked on a local site just yet, please be sure that both Docker and DevKinsta are entirely closed and up to date, then delete the content of the DevKinsta’s folder in ~/DevKinsta and finally open DevKinsta once again

I deleted all the folders in any way related to DevKinsta before reinstalling it. And Docker was emptied and closed too, so I don’t think that’s the issue?

I just wanted to be sure that the error code wasn’t changing after this process. Can you please be sure to close both Docker and DevKinsta, then open the terminal and run the following command:

sudo ln -s "$HOME/.docker/run/docker.sock" /var/run/docker.sock

Once done, you can retry to open DevKinsta

1 Like

Sorry for the belated response but this actually did the trick! It is finally updating the docker images instead of getting stuck :slight_smile: Thank you very much for your help, much appreciated!

1 Like

Thank you for the update @MDU, glad that worked!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.