Devkinsta cant start due to NGINX Container not running

Trying to start DevKinsta which was running fine so long. But it brought up error DK0005. I did the restart of Docker didn’t work. I also deleted the containers and restarted with terminal command; docker volume prune etc. from the other bug report I found. Even if Devkinsta then rebuilds the containers, the NGINX container will stop running and keep in mode “Restarting” but never doing so.

I am running it on MacOS 12.4
Devkinsta Version 2.7.0 (
Docker 4.10.1 (82475)

Find a screen of Docker statuses. NGINX log as DM no probs. Thanks for your help!

Hi @Mikyboy, thanks for reaching out. Can you use this command in your terminal and share the error/output?

docker logs -f devkinsta_nginx

Does it look anything like what we encountered here?

Yes it does, i also saw the SSL error in there. I have created the Certificate through the terminal commands there. Deleted Nginx in Docker. Restarted Docer, restarted Devkinsta, same issue still.

Can you please share what the container log says? Is it saying that the exact certificate that you created is not there?

Hold on no its missing the space44-1.local.crt… let me try something.

OK i have deleted inappropriate certificates. Created the space44-1 version. But as there is also a space44 project it now mentioned in the log the space44 certificate is missing. So I tried to create that one. But for some reason now the command lines don’t make it happen anymore.

OK i did a blunt approach. I have now just duplicated the existing key and crt file and renamed them to the missing ones. It worked! nginx immediately started once name was updated.

OK the database was corrupted but no probs, I just pulled a new version from the server, luckily it was all on staging already.

Thanks for your help though you brought me on the right track here @Kevin !

1 Like

Oh no next error comes up now:

Failed to import database dump.

Hmm can you look into your main.log to see what the exact error is? Is it an SQL error? Maybe something SSH related?

I deleted the complete DevKinsta installation as the pages are all live. So wasn’t an issue to pull them again to local. Its fixed now the hard way but worked :slight_smile:

Thanks again!

1 Like