Devkinsta's Cancell Maintenance Stuck

i am trying now but its stopping with broke pipe error in 200 mb

And some time it gives this error

Ah, okay, that error again. I saw that in a different log you gave before. Can you try following the instructions that the error is giving you? Basically this:

I’m not sure where this is on Linux, but on Windows, the DevKinsta storage directory looks like this:
image

If you go into the “.ssh” directory (it might be hidden for you), you need to open the known_hosts file
image
That’s where you would need to delete “line 29” of that file.

Since you are on Linux, the known_hosts file might actually just be /root/.ssh/known_hosts

The Kinsta entries will have your site’s external IP address. Most start with “34”
image

You just need to delete the line that the error is mentioning. We also have an explanation of this here

Should I have to delete all entries with 35 ??

Try only deleting the “line” mentioned in the error to see if it stops happening.
Otherwise, yes you could delete all of the entries, you should just backup the contents of the file just in case.

I will look after that if i stuck on ssh error again but want to know in which line we can find the ip , i didn’t find that and whats the solution for broken pipe does this problem belongs to ssh

It looks like you aren’t getting the SSH error now at least. So the errors you are getting can happen if the connection is being lost and it seems that maybe it’s because of how large some of your files are. Do you have very large files somewhere like wp-content? Or is the large size due to the database?

We had an issue like this in the past but that was fixed for everyone a while ago. I’m going to have more tests done on Linux to make sure this isn’t the same issue and have our devs investigate.

Thank you for your patience here. I will update you tomorrow. For no, you can still try a manual migration from DK to Kinsta: How to Migrate a WordPress Site on Your Own (With No Downtime)

I have file of 5 gb i am trying to push it from devkinsta.May be it has some big files too.

Does manual migration is possible for multisite too ?

Yes, it works for multisite as well. You can use a plugin or do it manually

Thanks kevin i will try it tomorrow and get back to you.

1 Like

Hi Kevin, I have freshly created another env and push the site it works fine and after some changes when I try to push it gives error but only database is pushed. Whats the problem . I will send you the main.log file in message

Hi @PuspaRaj_Subedi, yes please send me the main.log. There is also a new version of DevKinsta, 2.6.0 that you can update to.

hi kevin,

the error is in 10056 line. I have given this line because i am updated some things in local which makes lots of line in main.log file.

I am getting the same error as the previous.

I schedule my push to kinsta for weekend only. So, please look after my issue to solve it.

Regards,
Puspa Subedi

main.log (884 KB)

Hi @PuspaRaj_Subedi, can you please update your DevKinsta version then retry? Your logs show that your were version 2.4.1, can you update to 2.6.0 then try again and share the log?

Even if that doesn’t fix it, we might get better error information when you update.

Also did you ever try a manual migration? Did that work?

I have try the migration with new staging it works fine but with the same staging i cannot, even i delete and recreate the staging site.

Hi kevin,

How can I update devkinsta in linux. Does my previous devkinsta site remain the same?

Thanks,
puspa subedi

Hi yes, @PuspaRaj_Subedi, if you just download and run the installation again, it will only replace the application files. It will not delete your website.

Hi Kevin i have update my devkinsta but still facing same error .
main.log (356.8 KB)

Hi @Kevin i am waiting for your response.

Sorry @PuspaRaj_Subedi, it was a holiday but I am back. So since it’s still the same error but it only occurs with this specific staging, I think the problem is with the files that are currently on that staging environment.

Can you please private message the staging URL to me? I will properly reset it so that there are no files. That might allow the Push to work without this error.