DK0021 - WordPress site setup failed

Q: Date/Time this occurred (Provide your time zone also)
A: April 18, 2023 5:00pm MST (and many times before)

Q: DevKinsta Version
A: 2.10

Q: OS Version
A: Windows 11

Q: Docker Desktop Version
A: 4.18.0

Q: Were any error codes or messages observed? If so, what were they?
A: DK0021

Q: Detailed Description of the Problem
**A: I have tried adding the /wp/wordpress-6.2 folder to various places so that DevKinsta doesn’t have to use cURL to download the latest version of WordPress.

I have tried making sure the following folder did not exist or was deleted: /users/[user]/AppData/Roaming/DevKinsta/installers

The folder never existed, so I manually added it to see if it could work: /users/[user]/AppData/Roaming/DevKinsta/installers/wp/wordpress-6.2

Still getting DK0021

I have restarted DevKinsta and Docker multiple times.

I cannot install a new site.

I am getting to the point with DevKinsta where I get so many errors without resolution that it is growing unreliable in my mind and I am putting off working with it.

Hi @Chevas :wave:

Thank you for reaching us out!
The “WordPress site setup failed DK0021 ” error usually could be due to a local issue/system or network error issue when DevKinsta tries to use cURL to download WordPress.

If you keep getting that DK0021 error even after you’ve restarted DevKinsta and Docker multiple times, then you can try to add the WordPress files manually.
Please try to do the following:

  1. Close and Shutdown completely both DevKinsta and Docker. Then download the latest WP version 6.2 from this URL to your local PC:

  2. Remove anything inside this \wp\ sub-folder, something like this:
    and then extract that .zip file you just downloaded before into that sub-folder/path above, and make sure the folder names match as shown in the screenshot I took from my Windows computer below (e.g. wordpress-6.2 for WP version 6.2):

    And inside that wordpress-6.2 subfolder (e.g. C:\Users\yourusername\DevKinsta\wp\wordpress-6.2 ) looks like this:

  3. After this, please re-launch DevKinsta and try creating a new WP site again and see if you’re no longer getting that DK0021 error

Hopefully the solution above would help to solve this DK0021 issue you’re experiencing on your local computer. Same solution seemed to be working fine for other users as mentioned in the other thread here and here as well .


I tried these exact steps, ensuring I closed and fully quit DevKisnta and Docker. I removed any installation files as you specify in step 2 (but there weren’t any), and then manually added a folder that contains WordPress (unzipped).

My installation path is:

And then with WordPress:

Restarted DevKinsta (and thus Docker), tried to install a new site, still getting DK0021.

Seeing this a lot:

[error] [ipcMainStep] Error in operation SITE_CREATION, step baseapp: Error: Encountered an error: RangeError [ERR_CHILD_PROCESS_STDIO_MAXBUFFER]: stderr maxBuffer length exceeded

Thank you for your reply.

As I can see on my Windows 10 computer, that path has been created by DevKinsta by default when it’s installed: \Users\[user]\AppData\Roaming\DevKinsta

(mine is under the: C:\Users\iagus\AppData\Roaming\DevKinsta )

And the WordPress files/folders would be downloaded and extracted/unzipped inside the “Site path” set in the DevKinsta’s settings - by default it’s set to: \Users\[user]\DevKinsta .
(in my case, the WP would be saved inside the : C:\Users\iagus\DevKinsta\wp - as I showed in my previous screenshot before)

Please kindly check your DevKinsta → Settings (look for the “Site path” section), and then open your Windows file explorer and go to that same path/subfolder (e.g.: C:\Users\yourusername\DevKinsta ), and remove anything inside the “wp” subfolder there (if any) and follow the step 2 and step 3 that I suggested in the previous reply? and see if that will help?

The same error you provided:

[ERR_CHILD_PROCESS_STDIO_MAXBUFFER]: stderr maxBuffer length exceeded

was also mentioned in that other thread , and the solution was the same (and was confirmed to be working by the other user there).

Hopefully it will be working the same for you :crossed_fingers:


Thanks for your reply and help.

The missing keyword was “site path”, which I didn’t see mentioned in the other 2 threads.

It’s working. WordPress (unzipped) needs to be in the “site path” folder specified in settings of the DevKinsta app.

I had specifically changed the default location of DevKinsta’s Site Paths to be somewhere else so they get auto-backed up. Therefore, it wasn’t obvious to me where /wp/wordpress-x.x should go.

You’re most welcome @Chevas ! :smiley:
Glad that it’s now working as expected from your end! :+1:

Yeah, that’s what I thought as well and so I mentioned to check the DevKinsta’s “Site path” in my second reply! :wink:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.