Error DK0021 Wordpress site setup failed

**Q: Date/Time this occurred (Provide your time zone also)
13.12.22 23.00 CET

Q: DevKinsta Version

Q: OS Version
Windows 11, 22H2

Q: Docker Desktop Version

Q: Were any error codes or messages observed? If so, what were they?

Q: Detailed Description of the Problem
I can’t create a new site since I always get the error “WordPress site setup failed DK0021”
I tried some approaches shared here already but I cannot find the installers directory.


Hello Nick @nick1231 :wave: welcome to DevKinsta community!

I’ve just tried to reproduce this on my Windows machine (Windows 10 pro though as I don’t have Windows 11) with DevKinsta 2.9.0 and Docker Desktop 4.15.0 and could create a new local WordPress site just fine (see screenshots below) :

I suspect that “WordPress site setup failed DK0021” error seems to be a local issue on your Windows 11 machine perhaps (could be due to corrupted WordPress .zip file that has been downloaded to your local machine, or could be due to something with your system or network that might be blocking the cURL request from DevKinsta to download WordPress.).

Can you please try to remove/delete everything under this sub-folder on your local Windows 11 machine (something like this):


(replace the yourusername with your actual local Windows user account)
After that, close your DevKinsta and re-open it and see if you can then create a new WP site with it (if DevKinsta is able to download the WP zip file properly) ?

If DevKinsta still unable to get the WordPress zip file from the source (via cURL), then most likely something with your local network/system/firewall that may be preventing the cURL requests. And if that’s the case, you may want to add the WordPress files manually as also mentioned in the other thread here and here as well (which seems to be working as a solution, and see if this same method will help you).

Hopefully that will help and please let us know the results! :smiley:


Thank you very much.
The third step is now working but now step nr. 4 is failing.
I don’t get any error code for this one it just asks me for permission to amccess the CMD and then fails.


Hey @nick1231 ,
can you please send me the content of the main.log file over DM?
You should be able to find that easily by clicking on the question mark icon at the bottom left of DevKinsta and then selecting “Reveal log file in file manager”.



Hello again Nick! :wave:

My colleague Alessandro has informed me that you’ve been working with him in private message (PM/DM) but the issue has not been fully resolved yet, and he asked me to test and check further.

So, I checked on my Windows 10 machine again, and tried to replicate this case.
On the step #4 (Updating hosts file), the Windows would prompt us to accept the “User Account Control” as shown below for example (and we should click the “Yes” button to accept/allow the CMD to run that .bat file - which I suspect would modify the hosts file inside the c:\Windows\System32\drivers\etc\ folder)

When I tried to click the “No” button there, the DevKinsta returned with the same error you showed in your last screenshot above - this what I got:

So I just hit the “Retry” there and got prompted once again to accept the “User Account Control” (clicked Yes ) and it worked just fine!

(and it also passed the step #5 - Updating DNS server )

Could you please try again from your end and see if that will be working properly to solve this issue?

Also, I tried further to alter/change the “User Account Control” settings, from this (default one that was set by Windows 10 I think):

to this:
(which is not recommended by Windows - as it will NOT prevent potentially harmful programs from making changes to our computer)

Though with this settings, when I tried again in DevKinsta (on the step 4 mentioned above) I was not prompted with that “User Account Control” pop-up.

It’s all depends to you on how you would like to keep this “User Account Control” settings on your computer. I would still recommend to keep it as set by default by Windows, and to just accept the “User Account Control” pop-up with Yes button each time you’re prompted when creating or deleting site in DevKinsta.

Please let us know again if this helps to resolve the issue in question, and let us know again with the results!


Hey agus,

So I tried your approach where I deny the access first then click retry and allow it.
It just fails both times.

The approach where I set the User Account Control to the lowest setting also did not work.

Do you have any other ideas how I could fix the issue?

I also went to the folder where the bat file which is supposed to be executed should be located but I could not find it. So maybe I’m missing the bat file for some reason? Is that possible?
But that probably isnt the issue since I suppose

Thank you.

Hey Nick!
I was not working during the weekend, and am sorry for the late reply/response :smiley:

That’s really strange indeed :thinking: and I don’t think it’s DevKinsta related issue at all, but something with Windows users/roles permission perhaps? still unsure though as I couldn’t replicate this case on my Windows 10 pro machine and I don’t have any machine with Windows 11 O/S here.

With the “User Account Control” settings set to “Never notify”, did it prompt you to accept that “User Account Control” to execute the CMD ?

I’m still not sure either if it’s related to Docker settings or not, but you may want to check your Docker Desktop settings, and see if the “[ ] Use the WSL 2 based engine” is checked or not? I left it unchecked on my Docker Settings (on my Windows 10 machine) and I only use the Hyper-V.
In case you enabled that option, may worth try to disable that WSL2 (uncheck it, and restart the Docker Desktop) and then also close DevKinsta completely and re-open and test again? if that makes any effect?

I’m also wondering if you have any other computer with different OS (Windows 10 pro maybe?) and see if it’s working there just fine there?

And yeah, I also checked into the folder where the bat file would be executed, but couldn’t find it either (I think that’s automatically generated and removed on the fly by DevKinsta, so we wouldn’t be able to see it) and this should not be the case I think.