Downloading existing WordPress Site not working on Windows

Hey, everyone! I’m trying to import an existing site that uses bedrock in Windows and is not working. I’ve followed the steps below, but still not working:

1)Putted the site host in my host file
2)Changed the root path in nginx editor to where is my wp-config (current/web)
3)Changed .env with the right credentials
4)Updated wp_options in database
5)Disabled firewall
6)Deleted docker containers and reinstalled Kinsta.

The main.log show the following error:

[2023-12-27 03:47:46.544] [info]  [containerExec] Command 'cd public/p43north && wp --allow-root --skip-themes --skip-plugins db size --size_format=b --url=http://p43north.local' on devkinsta_fpm finished with exit code 1
[2023-12-27 03:47:46.545] [error] Error: [31;1mError:[0m This does not seem to be a WordPress installation.Pass --path=path/to/wordpress or run wp core download.

And the browser shows a DNS_PROBE_FINISHED_NXDOMAIN

Is there anyone having the same problem? How can i fix it?

Hello Rogério, welcome to Kinsta Community! :wave:

I’m sorry to hear that you’re having issues with DevKinsta, This is somewhat expected, as DevKinsta was built to work with standard WordPress installs and a lot of it’s functionality when pulling live sites is centered around wp-config.php.

Our developers are looking into a long-term solution for this, however, at the moment, we have no way to automate this process to run the same as with the standard WP installs.

In this post, my colleague Kevin explained the issue and what can be done as a workaround.

You could try the following:

  1. Add wp-config.php in ~/public with the connection credentials (regardless of that not being needed for your Bedrock install)
  2. Add a wp-cli.yml file in ~/public that sets the path to your wp directory

The DevKinsta would be then basically used for transferring files and database, as it would require search and replace in both files and database even after the workaround to get it going.

We’re sorry that we don’t have a more straightforward solution at the moment, but we do hope to have one in the future.

Once again, welcome to Kinsta Community!

P.S. In regards to the DNS Probe Finished, it is possible that there’s an error in your hosts file and the way you’re pointing via the file itself. Please recheck it to make sure.

My site already has the wp-cli, as we can see in the image. Is there any other solution?


Hello again,

Did you also add wp-config.php in ~/public with the connection credentials (regardless of that not being needed for your Bedrock install)?

Yes, my public folder has the wp-config and wp-cli file, but it still doesn’t work :/, even if I pull it from kinsta again and restart the containers. About the host file, here’s my config:

Hi @roger067!

I’m sorry to hear you’re still having difficulty with importing your Bedrock site into DevKinsta.

After further researching into this issue we have discovered that Bedrock has provided documentation on how to create a Bedrock site using DevKinsta. You may find the link to this documentation below:

This would be more of a manual import process, as first you’d create a new empty site within DevKinsta. Then, you’d clone your Git repository into the correct file path as mentioned in the Bedrock documentation. After that you would need to import the database separately. However, this might get you going with DevKinsta as the actual import/site creation process should not fail.

Below you may also find a link to our documentation that will help explain how to manage the database using Adminer so you can import a database backup you may have:

Please let us know if this has helped, or if you need any further assistance.

Best regards

Hi @Andrew !

I was pretty sure that this solution would work, but the same error persists:

[error] Error: [31;1mError:[0m This does not seem to be a WordPress installation.Pass --path=`path/to/wordpress` or run `wp core download`.

First, I tried to clone my WP site into the new empty site, but as I said, the same error continues to occur. Then I tried installing bedrock with composer instead of cloning my repository into the new empty site and this error occurred:

PS: The database has been imported and is working fine.

I’m starting to think that this project will only run on Mac devices :confused:

Hi @roger067!

Thank you for your reply, and sharing that screenshot showing the permission denied error. To clarify, are you cloning the site files from a Git repository into DevKinsta? Or, are you cloning/importing the site through DevKinsta directly?

If you are importing/cloning via DevKinsta, would it be possible to clone the site using the Git application directly to clone your site’s GIt repository into the DevKinsta site directory? Also, just to confirm do you have the site within a Git repository that you can clone from?

The permission denied error you are seeing would indicate the user running the Composer application does not have the proper permissions to create files/folders in that directory. To confirm, does the user you are running Composer have read/write permissions to the folder you are installing Bedrock into?

We look forward to hearing from you!

Best regards

Hi, Andrew,

I didn’t import via devKinsta, I created the empty site and in the folder I cloned it directly from the repository via git clone, and the error still occurring.

About the permission denied problem, I tried to create a simple bedrock site from the empty custom site and then install bedrock with composer running the commands as administrator, but the following error message appears:

 svn was not found in your PATH, skipping source download

Hi @roger067!

Thanks for your reply, and clarifying how you are importing the site.

I have researched into the “svn was not found” error you are seeing when trying to install Bedrock with composer. I found a forum thread where another user was experiencing a similar issue here. It appears however that getting packages via SVN is a fallback method. Are you seeing any other errors earlier on that mention any connection timeouts?

I am also going to discuss this further with our team internally to see what options might be available.

Best regards

Hi @roger067 :wave:

I noticed that you mentioned you changed the root path in the DevKinsta Nginx editor for the site to “current/web”. However, I believe that the path in your wp-cli.yml file should be updated to reflect the appropriate location of your WP files. Depending on where the files are stored, the path in the wp-cli.yml file should be either:

root /www/kinsta/public/site_name/web/;

path: web/wp
  docroot: web


root /www/kinsta/public/site_name/current/web;

path: current/web/wp
  docroot: web

I hope that the above information helps! :slightly_smiling_face: