Error in operation SITE_CREATION, step baseapp: Error: EACCES: permission denied, copyfile error

Q: Date/Time this occurred (Provide your time zone also)
A: 2023-07-31 10:18:59 Central Daylight Time

Q: DevKinsta Version
A: 2.11.0

Q: OS Version
A: Pop!_OS 22.04 LTS

Q: Docker Desktop Version
A: N/A, I have the Docker CLI installed: Docker version 24.0.5, build ced0996

Q: Were any error codes or messages observed? If so, what were they?
A: Partial log below:

[2023-07-31 10:34:36.522] [info]  [installApp] Installing app
[2023-07-31 10:34:36.522] [info]  [getDevKinstaPath] get DevKinsta path
[2023-07-31 10:34:36.522] [info]  [isWslMode] check if docker runs on wsl mode
[2023-07-31 10:34:36.523] [error] [ipcMainStep] Error in operation SITE_CREATION, step baseapp: Error: EACCES: permission denied, copyfile '/opt/DevKinsta/resources/resources/index.html' -> '/home/nate/DevKinsta/public/example/index.html'
[2023-07-31 10:34:36.530] [info]  [ProgressIndicator] { isFailed: false, isOpen: false }
[2023-07-31 10:34:36.548] [info]  [ProgressIndicator] { isFailed: true, isOpen: false }
[2023-07-31 10:34:36.550] [info]  [ProgressIndicator] { isFailed: true, isOpen: true }

Q: Detailed Description of the Problem
A: When I attempt to create an empty site I get an error inside of DevKinsta that says “Something bad happened.” I tried changing the permissions of the files to root but that didn’t work. I’ve also tried uninstalling and reinstalling Dev Kinsta (purging the Docker containers/volumes as well) but haven’t had any luck with that yet.

Hello @Nathan_Hill ,

Thank you for reporting this to our community! :bowing_man:
I’m using Ubuntu 22.04.2 LTS and the same Docker Engine/CLI version, as well as the same DevKinsta version (2.11.0).

I could replicate the same issue (bug) on my end with the above environments - though previously I tried and it worked fine on the previous DevKinsta version (2.10.0) - when creating an empty site.

I compared those processes on both DevKinsta versions, and noticed that in DevKinsta 2.10.0, after I clicked the “Create site” blue button (to create new empty/custom/non-WordPress site), it then prompted me to enter my linux user’s password (as the Super User)

but I’m not sure why, that when I tried in DevKinsta 2.11.0, after I clicked that same “Create site” blue button, it didn’t prompt me to enter the authentication/credential as the super user - so that’s the difference here (and guess it maybe a bug with this DevKinsta 2.11.0 version), and I got the same “Something bad happened

also I got the same error message when I was tailing the main.log file:

Then I immediately check my ~/DevKinsta/public/ folder and noticed that new local site ( example folder ) had root:root user ownership:

(no wonder that we got that similar error:
[error] [ipcMainStep] Error in operation SITE_CREATION, step baseapp: Error: EACCES: permission denied, copyfile '/opt/DevKinsta/resources/resources/index.html' -> '/home/agus/DevKinsta/public/example/index.html' )

[TEMP] Solution
As a workaround, I went ahead and changed that new created “example” folder’s ownership to my linux user account (with something like this: sudo chown -R agus:agus example/ )

After that, I went back to my DevKinsta (where it was showing that “Something bad happened” screen) and clicked the “Retry” button - it then passed that process and then prompted me to enter to authenticate with the user password:

then, it continued to process the other steps and completed just fine:

and the “example” site’s folder and its contents are showing these:

The local example site is also accessible when I tried to open it on my FireFox browser:

So you may want to try the same “temporary” solution as I did above and see if you can create that empty site on your local computer using DevKinsta.

I will also report this “bug” to our internal DevKinsta developers, so they will be aware about it and can check further. Though I can’t promise anything when the fix for it will be released in the future (in the next DevKinsta version).