Https - certificate is not valid


I read some posts but couldn’t find a fix to my issue.

I installed the latest version of DevKinsta (great thing!), dowloaded my live website successfully, but I still get a red warning in Chrome “Not Secure”, and the “https://” is double stroked in red.
Message: “Certificate is not valid”.
I tried to edit the certificate to make it “always trust” => not better.
My computer is a MacBook pro running Big Sur.

Anyone to help me?

Thanks ! :slight_smile:

Hi @Marsux, thanks for reaching out. It’s honestly better to just ignore this warning since it’s expected. If you absolutely want to add the local certificate to Chrome’s trusted authorities, the instructions here (starting from the user’s “EDIT”) might get this working for you: ssl - Getting Chrome to accept self-signed localhost certificate - Stack Overflow

I was able to get a secure certificate Incognito by following those instructions. But again, it’s not really a warning that you need to worry about.

Hi @Kevin , thank you for your answer.

I followed the instructions that you mentioned without success… The strange thing is that I don’t have this issue on my iMac but only on my MacBook. Both use the same OS, same Chrome, etc.

Maybe it’s not a big deal, but I read here and there that you can get “bad surprises” with your code when you push it in prod, if your dev environment is not ssl-secured… Not correct?

Thank you ! :slight_smile:

Sorry to hear that @Marsux!
So what’s important is that your website is using https:// URLs. When you move back to Production, Chrome will show everything as “Secure” as long as your Production environment has a valid SSL certificate Installed.

It only shows “Not Secure” now because the local SSL Certificate added by DevKinsta isn’t trusted by your browser; there’s no issue with the website.

For a brand new website, all you really need to do is go to your WordPress settings and make sure your Home/Site URLs are using https. This will carry over into Production when you replace the .local URL with your Production URL.

So since your Dev environment is based on your Production site, there’s nothing to worry about when it comes to SSL. You can just ignore the red “Not Secure” and do your developing like normal. This is just Chrome being strict with SSL on your MacBook.

Problem would happen if you changed your URLs from https:// to http:// in Development then forgot to change them back before pushing your changes to Production.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.