HTTPS Not Working - Invalid Certificate (MacOS)


For whatever reason upon enabling HTTPS on any site within DevKinsta’s site settings and then navigating to the local site in Chrome, I am getting the “your connection is not private” warnings. Turning off HTTPS and back on again doesn’t work.

Do I need to manually trust the certificates generated for each site in Chrome? I figured it should work without having to do that but I thought I’d ask just in case that was the solution.

Thank you in advance!

Hi @BrandynF . It sounds like the certificates may not be generating. Are you on Mac or Windows? When creating a site, are you presented with a dialog box to enter your machines password?

Hey @michael

I’m on MacOS Big Sur right now. When creating a site or pulling from Kinsta I am presented with those certificate dialog boxes to enter my machine’s password. It doesn’t give any error messages that the certificates weren’t generated after entering my password and when inspecting the certificates in Chrome it looks like it’s generated but shows “this certificate has not been verified by a third party.”

Thank you for the additional info, @BrandynF. Our developers are aware of an issue with macOS Big Sur 11.1 and the creation of SSL certificates. For the time being, it’s safe to manually trust the certificates.

It’s also possible however that the error would appear in cases of mixed HTTPS and HTTP content on a page. Running a Search & Replace via plugin or the database may help catch those.

Thanks for the help, @michael

That must be the issue then! I’ll go ahead and manually trust those certs and I look forward to a future update that may fix the issue. I did try to run a search & replace just in case but that didn’t do anything.

Thanks again for the help!

1 Like

This is also a problem on windows 10… I have enabled SSL and HTTPS yet I am still getting this warning…

This works for me on my Macs:

  1. Open Keychain Access app
  2. Locate the new .local domain name in the System keychain and double click to open the certificate
  3. Click on the caret to the left of “Trust” and select “Always Trust” in the first dropdown
  4. Close Keychain Access and restart your browser


Great tip @sznngoodwin !

I’m having this issue as well, the fix suggested before fixed the issue when visiting the website, but it also affects the cron function of wordpress.

at: /wp-admin/tools.php?page=crontrol_admin_manage_page
I see the following error:
cURL error 7: Failed to connect to fairbee.local port 443: Connection refused

Any suggestion on how to solve this? I’m guessing I should somehow be able to get into the docker image to trust the certificate there?

Hey @fairbee. Welcome to DevKinsta! Crons should be able to function as normal on DevKinsta, but it may depend on the cron job that’s attempting to run. We’ll take a look at this :slight_smile:

thanks :slight_smile: I assume it has to do with the same SSL issue, since cURL from terminal had the same result until I used the “trust always” setting suggested before.

I’m having this issue again. It has been working for months, than stopped working last week. I’m on MacOS Ventura 13.1. The certificate is already marked as always trust on keychain, but still have the issue. Tried uninstalling DevKinsta, Docker, installed again, and created a new site. Still not working.

Hello Anderson @andergmartins :wave:

I don’t have Mac here and can’t replicate the issue :smiley: , but I saw this post from other user that followed the suggestion there ( Thank you @krisroadruck :bowing_man: ) - which seemed to help to solve the Cert/HTTPS related issue with Chrome (on Mac OS Ventura).

Please kindly check and see if that workaround will also help to solve the issue you’re experiencing.



Thanks @Agus Yes, I can confirm that copying the certificate from “login” keychain and pasting on “system” as suggested on SSL update failed - #3 by krisroadruck works for me as well. Thanks for pointing me to there.


Awesome! glad to hear the solution provided there works for you as well @andergmartins :+1:
Thanks @krisroadruck once again for sharing the information/workaround! :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.