Imported from Live - launched local site only shows the site URL repeated many times in HTML body

Dev environ: Mac OS 14.4.1 - DevKinsta 2.13.2 - Docker 4.29.0

The import seems to have gone smoothly, but when I run the site all I see is the site URL repeated many times in the browser.

https://sbtdc.localhttps://sbtdc.localmhttps://sbtdc.local$https://sbtdc.localLhttps://sbtdc.localjhttps://sbtdc.local5https://sbtdc.local6https://sbtdc.local>https://sbtdc.localqhttps://sbtdc.localghttps://sbtdc.local~https://sbtdc.localRhttps://sbtdc.localnhttps://sbtdc.local4https://sbtdc.local” … and so on.

Has anyone else seen this? Not sure how to fix it.

Hi @TonyBuxton ! :wave: Welcome to the Kinsta Community.

That typically occurs when there’s a plugin redirect or Home/Site URL setting that is referencing the domain, and redirecting while adding the domain. When trying to reach the base .local domain in a browser with the developer console open (F12 in most browsers), under the Network tab, what headers are showing for the loop request?

Hi @jackirish. Thank you for the quick reply! The following shows on the Network > Headers tab:

URL: https://sbtdc.local/
Status: 200
Source: Network
Address: ::1:443

:method: GET
:scheme: https
:authority: sbtdc.local
:path: /
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.9
Connection: keep-alive
Host: sbtdc.local
Sec-Fetch-Dest: document
Sec-Fetch-Mode: navigate
Sec-Fetch-Site: none
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/17.4.1 Safari/605.1.15

:status: 200
Content-Type: text/html; charset=UTF-8
Date: Mon, 29 Apr 2024 12:23:52 GMT
Server: nginx

Hello Tony,

The headers you’ve sent show 200 response code which indicates a successful request.

If you visit another URL, lile sbtdc.local/wp-admin, are you able to login and disable plugins?

Kind regards

Hello. Unfortunately, any page I attempt to visit shows the same thing - the site URL repeated many times. I am not able to access wp-admin to disable plugins. In fact, the “WP Admin” button is disabled on the DevKista app site info page.

Hi @jackirish and @Vladimir_Milosavljev,

I found that the “wp-config.php” file is being overwritten on import to DevKinsta. The content of the file is just the site URL repeated many times.

I deleted the site and re-imported. Same thing - the “wp-config.php” file is being overwritten. Any thoughts?

The “wp-config.php” file was the issue. I pulled a copy down from the live server, updated the credentials, and now the site loads with no problems.

Hi @TonyBuxton , glad to hear that it’s working! That’s strange - I haven’t seen that happen before personally :thinking: Does it happen on a new import after the manual adjustment/update to the wp-config.php file?

Thanks! As far as I can tell it only happens during the new import process. Not sure if this makes a difference - our site is not a standard WP build. We are using Timber (v1) / Twig for development.

Hello Tony :wave:

It could be related to it as non-standard WP have different config files. Have you tried commenting out the cache route line in Twig config file?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.