Install Node and Gulp

Hi, I already have NPM and Gulp installed in Windows for a different repo I work on - and I think somehow this is not allowing me to install Gulp in my Docker instance created by DevKinsta - I am also attempting to use ‘npmlink gulp’ but am getting ‘illegal operation on a directory, symlink’ error - I see from other threads that people have been able to create node-modules so this must work somehow. Is there any docs on installing node and gulp for DevKinsta? Thanks

Hello there @adriaan.wakefield :wave: and welcome to Kinsta Community!

I’ve just tested this on my Windows 11 machine, and could install Node/NPM as well as Gulp within the devkinsta_fpm docker container (which runs on Ubuntu 20.04). Though I only tried to install them and don’t have any experiences to use them with my local sites (in DevKinsta).

You might want to try the same with the following steps to install them in that docker container:

  1. open CMD to open the command prompt on Windows

  2. In that Command Prompt window, you may want to enter to the devkinsta_fpm docker container with this command line:
    docker exec -it devkinsta_fpm bash

  3. I then installed Node by following the installations steps (1-3) here

as we can seen from the screenshot above, I was able to install it, and can see the node -v and npm -v returned with their versions installed.

  1. I then continued to install the gulp-cli ( with -g parameter ) as shown here

and as we can see from the screenshot above, gulp was installed and I could run gulp -v that returns with the CLI version.

  1. After that I also followed the instruction there to run: npm install gulp

as we can see from the above, the command seemed to be successful (and it created node_modules folder and the other 2 files: package-lock.json and package.json )

Hopefully this will help you to install Node/NPM and Gulp on your devkinsta_fpm docker container. :crossed_fingers:

Best regards,

Thanks so much Agus! This worked perfectly, I think the key was I did not realize the fpm container was where I needed to access a terminal and run all the commands. I was trying from the main WSL console, also tried from the VS Code console which half works but I think a lot of the paths do not map out causing issues. When I wiped my node_modules folder, installed node on fpm per your instructions and installed my dependencies all worked first time! I actually just popped into Docker for Desktop, went to the devkinsta_fpm container and went to the EXEC tab rather than using CMD and bash but all works the same of course. Thanks again!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.