Keep getting DK0006 Error when trying to install DevKinsta


I’m currently trying to set up DevKinsta on my machine, and I and consistently getting the DK0006 Error.

Description: Couldn’t download docker images.

DevKinsta couldn’t load the required Docker images.

The download freezes a quarter of the way through, and after that I am unable to fully close the DevKinsta app, and have to restart my machine in order to close it.

I’m currently on a Macbook running MacOS Monterey (12.6) with the Apple M1 Pro Chip.

I’ve also ensured that I’ve downloaded the correct Docker and DevKinsta versions for my machine along with ensuring enough Docker resources are available.

Does anybody have any suggestions on how to resolve this issue?

1 Like

Hi @Steffan_Carrington, thanks for reaching out. So if DevKinsta every hangs up, you can force it to quit: How to force an app to quit on your Mac - Apple Support

That should save you from having to restart. That being said, please share your main.log file with me privately. It will be here on MacOS: /Users/[USERNAME]/Library/Logs/DevKinsta or ~/Library/Logs/DevKinsta

1 Like

Hi @Kevin ,

Thanks for the response, force quitting the app from the Force Quit menu doesn’t quit the app properly either (which led me to the restart). It says it quits the app, but then when I attempt to reopen the app it opens in the same state as it was when I force quit it.

Screenshot 2022-10-20 at 14.35.55

I also don’t see the DevKinsta directory in the Logs either :disappointed:

That’s very odd; I haven’t used DK on Mac in a while but force quitting used to work. Perhaps there’s another instance of it running.

What are you seeing within Docker Desktop? Are any of the images being downloaded? I want to make sure it isn’t just being held up at one.

I don’t see any images within Docker, my Docker dashboard is empty.

I’ve also checked that there is enough resource allocated in Docker

Can you please try a manual image pull like this from the command line? I want to be sure it isn’t a network issue
docker pull kinsta/devkinsta_nginx:1.2.6

1 Like

Running it via the command line worked fine :slight_smile:

Do you have a list of the remaining images I need please? :pray: and I’ll add those via the command line instead.

1 Like

Very strange okay here are the ones I have:


I have now downloaded the required images, which now appear in Docker:

I then restarted my machine (to be able to quit DevKinsta), and opened Docker and then the DevKinsta app, it started with ‘Starting Docker’ before erroring out with the DK006 Error message again after 5 - 10 minutes.

Am I missing a particular Docker Image or?

I’m having the exactly same issue.
Even with all the images manually installed and docker running the setup process fails with the following error in the logs:

[2022-10-21 12:04:19.702] [info]  [dockerClient/isReady] Check if Docker client is ready
[2022-10-21 12:04:27.703] [info]  [dockerClient/isReady] Check if Docker client is ready
[2022-10-21 12:04:34.092] [info]  [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta_nginx:1.2.6
[2022-10-21 12:04:34.093] [info]  [dockerUtil/isImageUpToDate] Check if 'kinsta/devkinsta_nginx' Docker image is up to date
[2022-10-21 12:04:34.093] [warn]  [dockerUtil/isImageUpToDate] Failed to inspect image undefined
[2022-10-21 12:04:34.094] [info]  [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta_nginx, version: 1.2.6
[2022-10-21 12:04:34.098] [error] Error: connect ENOENT /var/run/docker.sock
    at __node_internal_captureLargerStackTrace (node:internal/errors:464:5)
    at __node_internal_exceptionWithHostPort (node:internal/errors:642:12)
    at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1157:16)
[2022-10-21 12:04:34.101] [error] Error: connect ENOENT /var/run/docker.sock
    at __node_internal_captureLargerStackTrace (node:internal/errors:464:5)
    at __node_internal_exceptionWithHostPort (node:internal/errors:642:12)
    at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1157:16)

OS: macOS Monterey 12.6 (21G115)
Docker Desktop: aarm64 v4.13.0
DevKinsta: Version 2.8.0 (

1 Like

This is odd; okay, I will try to get a virtual machine up to reproduce this. I’m also assuming you are both using the correct DevKinsta version for you Macs:

I’m going to ask our developers to look over this as well and will get back to you both!

Yeah I used the ‘Mac with Apple Chip’ option.

Thanks for looking into this Kevin :+1:

1 Like

Yeah, both binaries, docker and devkinsta, are also shown to be running as “Kind: Apple”, which means that they’re using native aarm64 (Apple chip).

Likewise, thanks for looking into this! Feel free to contact me, if you want to set up a remote debugging session with one of your devs.

1 Like

Hi @Kevin ,

Did you have any luck with this?

Hi @Steffan_Carrington and @jpb , I asked our devs to look into the error and based on what you shared, it’s a Docker issue:

[error] Error: connect ENOENT /var/run/docker.sock

I’m guessing this file really doesn’t exist on your machine? /var/run/docker.sock
Restarting your computer is supposed to resolve this, however you mentioned you already did this.

I found this thread which implies that there may be a hardware incompatibility with your Docker version, but that doesn’t seem right either: Docker starting error · Issue #2498 · docker/for-mac · GitHub

I will point out, though that this thread came out a day after Docker Desktop 4.13.0 was released so it’s definitely possible that there is an update issue as mentioned in the above thread as well.

I also recommend trying this out: Fix Docker VS Code Error: connect EACCES /var/run/docker.sock

We haven’t been able to reproduce the issue but thanks to your logs, we can at least narrow it down to Docker.

Hi @Kevin ,

Thanks for chasing this up.

I’m still getting the same error on Docker 4.12.0. I thought that maybe using an older version would solve the issue but no luck.

It looks like the issue occurs simply by updating regardless of what version it is. I know they are Linux instructions but they might also apply to Unix. It’s worth trying the suggestions here: Fix Docker VS Code Error: connect EACCES /var/run/docker.sock

If nothing works we’ll keep trying to reproduce this on our end.

I’m having the exactly same issue.

OS: macOS Monterey 12.6
Docker Desktop: v4.13.0
DevKinsta: Version 2.7.0

Thanks for sharing @Taka. Is this the first time you have installed Docker Desktop on your Mac?

4.10.1 solved all issues for me on macOS 13.0