Keep getting DK0006 Error when trying to install DevKinsta

Running it via the command line worked fine :slight_smile:

Do you have a list of the remaining images I need please? :pray: and I’ll add those via the command line instead.

1 Like

Very strange okay here are the ones I have:

justincormack/nsenter1
kinsta/devkinsta_adminer:1.2.6
kinsta/devkinsta_fpm:1.2.6
kinsta/devkinsta_mailhog:1.2.6
kinsta/devkinsta_nginx:1.2.6
mariadb:10.5.5

I have now downloaded the required images, which now appear in Docker:

I then restarted my machine (to be able to quit DevKinsta), and opened Docker and then the DevKinsta app, it started with ‘Starting Docker’ before erroring out with the DK006 Error message again after 5 - 10 minutes.

Am I missing a particular Docker Image or?

I’m having the exactly same issue.
Even with all the images manually installed and docker running the setup process fails with the following error in the logs:

[2022-10-21 12:04:19.702] [info]  [dockerClient/isReady] Check if Docker client is ready
[2022-10-21 12:04:27.703] [info]  [dockerClient/isReady] Check if Docker client is ready
[2022-10-21 12:04:34.092] [info]  [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta_nginx:1.2.6
[2022-10-21 12:04:34.093] [info]  [dockerUtil/isImageUpToDate] Check if 'kinsta/devkinsta_nginx' Docker image is up to date
[2022-10-21 12:04:34.093] [warn]  [dockerUtil/isImageUpToDate] Failed to inspect image undefined
[2022-10-21 12:04:34.094] [info]  [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta_nginx, version: 1.2.6
[2022-10-21 12:04:34.098] [error] Error: connect ENOENT /var/run/docker.sock
    at __node_internal_captureLargerStackTrace (node:internal/errors:464:5)
    at __node_internal_exceptionWithHostPort (node:internal/errors:642:12)
    at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1157:16)
[2022-10-21 12:04:34.101] [error] Error: connect ENOENT /var/run/docker.sock
    at __node_internal_captureLargerStackTrace (node:internal/errors:464:5)
    at __node_internal_exceptionWithHostPort (node:internal/errors:642:12)
    at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1157:16)

OS: macOS Monterey 12.6 (21G115)
Docker Desktop: aarm64 v4.13.0
DevKinsta: Version 2.8.0 (2.8.0.5344)

1 Like

This is odd; okay, I will try to get a virtual machine up to reproduce this. I’m also assuming you are both using the correct DevKinsta version for you Macs:
image

I’m going to ask our developers to look over this as well and will get back to you both!

Yeah I used the ‘Mac with Apple Chip’ option.

Thanks for looking into this Kevin :+1:

1 Like

Yeah, both binaries, docker and devkinsta, are also shown to be running as “Kind: Apple”, which means that they’re using native aarm64 (Apple chip).

Likewise, thanks for looking into this! Feel free to contact me, if you want to set up a remote debugging session with one of your devs.

1 Like

Hi @Kevin ,

Did you have any luck with this?

Hi @Steffan_Carrington and @jpb , I asked our devs to look into the error and based on what you shared, it’s a Docker issue:

[error] Error: connect ENOENT /var/run/docker.sock

I’m guessing this file really doesn’t exist on your machine? /var/run/docker.sock
Restarting your computer is supposed to resolve this, however you mentioned you already did this.

I found this thread which implies that there may be a hardware incompatibility with your Docker version, but that doesn’t seem right either: Docker starting error · Issue #2498 · docker/for-mac · GitHub

I will point out, though that this thread came out a day after Docker Desktop 4.13.0 was released so it’s definitely possible that there is an update issue as mentioned in the above thread as well.

I also recommend trying this out: https://www.davidhayden.me/blog/fix-docker-vs-code-error-connect-eacces-var-run-docker-sock

We haven’t been able to reproduce the issue but thanks to your logs, we can at least narrow it down to Docker.

Hi @Kevin ,

Thanks for chasing this up.

I’m still getting the same error on Docker 4.12.0. I thought that maybe using an older version would solve the issue but no luck.

It looks like the issue occurs simply by updating regardless of what version it is. I know they are Linux instructions but they might also apply to Unix. It’s worth trying the suggestions here: Fix Docker VS Code Error: connect EACCES /var/run/docker.sock

If nothing works we’ll keep trying to reproduce this on our end.

I’m having the exactly same issue.

OS: macOS Monterey 12.6
Docker Desktop: v4.13.0
DevKinsta: Version 2.7.0

Thanks for sharing @Taka. Is this the first time you have installed Docker Desktop on your Mac?

4.10.1 solved all issues for me on macOS 13.0

3 Likes

Hi @Kevin ,
Yes, tha is the first time.

I also have solved a problem to reinstall 4.10.1 Docker Desktop.

1 Like

Hey @Kevin,

This is now working for me using Docker Version 4.10.1. Thanks for all your help with this.

Thanks @hawaii-aloha for pointing me in the right direction with this too. :raised_hands:

2 Likes

That’s great to hear, everyone! I’ll go ahead and mark this reply as the solution with all the possible fixes that we have found based on information here: How to set DOCKER_HOST on 4.13.0 without /var/run/docker.sock · Issue #6529 · docker/for-mac · GitHub

  1. Downgrading seems to Docker Desktop 4.10.1 seems like a reliable solution for now.

  2. Another solution provided by the Docker devs is to manually create the missing Symlink like this:
    sudo ln -s "$HOME/.docker/run/docker.sock" /var/run/docker.sock

  3. Manually setting the DOCKER_HOST variable also seems like a possible solution via this command:
    export DOCKER_HOST="unix:///Users/YOURUSERNAME/.docker/run/docker.sock"

It seems as if the Docker developers are reconsidering this change so hopefully they release a more straightforward fix in a future release. Any changes we make to DevKinsta to accommodate this Docker update could break backwards compatibility with older Docker Desktop releases for Mac so we are holding off on updates for now.

Please let us know if none of the above solutions work and thank you all for contributing to the current solution!

2 Likes

Having the same issue on osx 11.7.1 with intel chip, even after downgrading to Docker Desktop 4.10.1. Reinstalled both Kinsta and docker a few times, restarted machine. Like someone else mentioned above, force quitting Kinsta wouldn’t work, I had to go into activity monitor and kill a still running Kinsta process or else the next time I clicked the Kinsta app icon it would just reveal the same window hung at starting docker. Solution #2 above seems to have fixed the installation issue (sudo ln -s “$HOME/.docker/run/docker.sock” /var/run/docker.sock).

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.