Keep having to restart DevKinsta And Docker - This site can't be reached - timed out

Windows 11
DevKinsta 2.13.1
Docker Desktop 4.27.2

I think I’m on the Hyper-V installation, but can’t remember.

If I am not actively loading local pages or editing things in WordPress, all local sites will eventually timeout. This usually happens within 5-10 minutes of non-activity.

OCCASIONALLY, if I leave everything open for a day, the pages will still load when I come back, but generally, they will start timing out within 5-10 minutes.

It doesn’t matter what local site I’m working with.

The only work-around is to restart DevKinsta AND Docker Desktop, then the pages will load again. If I try to just restart Docker, they won’t come back.

So right now, my workflow is restarting the apps 8-14 times per day and it’s really killing productivity.

All sites are running SSL and HTTPs and forced on 80 and 443 (but changing this didn’t matter).

Adminer always loads. It’s just the sites themselves that don’t.

Hi @Chevas,

I’m sorry to hear you are having difficulties with your DevKinsta WordPress site.

We tried to replicate this issue on both Windows 10 and 11, utilizing DevKinsta with WSL and Hyper-V but were unsuccessful in doing so.

This gives us a conclusion that the issue may originate from your local machine. So we would suggest you try to implement the following on your end and see if this could help:

Adjust Power Settings:
Check your power settings in Windows 11 to ensure that the computer is not entering a low-power state that could affect Docker’s operation. Adjust the power settings if necessary to prevent the computer from entering sleep or hibernate mode too quickly.

Firewall and Antivirus:
Check if your firewall or antivirus software is blocking Docker’s network connections after waking from sleep. Configure your firewall or antivirus software to allow Docker connections if necessary.

I hope this helps!

Best regards,

This is a bona fide desktop (not a laptop).

When plugged in, put my device to sleep after: NEVER.

Allow apps to communicate through Windows Defender Firewall

Both DevKinsta and Docker Desktop are enabled to communicate over private and public.

In other words, these configurations are set to allow functionality.

Hi @Chevas :wave:

I was wondering if the Resource Saver feature in Docker Desktop settings might be causing conflicts. since the site times out every 5-10 minutes when idle. You can try either increasing the limit or temporarily disable the feature to see if that makes any difference.

Alternatively, you can switch from Hyper-V to WSL from within the Docker Settings > General > Use WSL section. However, please note that doing so will delete all existing sites running on DevKinsta.

If possible, please test it on another machine to confirm if the same issue persists across all devices since we are not able to replicate this issue from our end.

Let us know how it goes!

Thank you Adrian—good suggestions, will try adjusting the resource saver. It was set to 5 minutes, so that’s telling and might just be the culprit. Will let you know.

I may consider WSL the next time I reinstall. A while ago WSL was running super slow, which is why I switched to Hyper-V. Not sure if that’s the case now.

1 Like

Hi @Chevas,

Please keep us updated on how it goes. Hopefully that will really resolve the issue. :crossed_fingers:
If ever something comes up, please feel free to respond here and we will be glad to help you out.

Have a great day!

After changing the resource saver in Docker Desktop from 5 to 30 minutes, I only had to restart DevKinsta and Docker once throughout the whole day. That’s a huge improvement.

Until I switch to WSL, this will work. There’s even an option to disable resource saver altogether, so if I need to, I can do that.

I’ll continue testing to see if this change is in fact the resolution. If the problem returns, I’ll let you know.

Thank you for the update @Chevas :pray:
Sure, please take your time with your testing (e.g.: to disable that Docker Desktop’s Resource Saver option and whatnot) and see if that would make any improvements and if you will see any difference/results again!

Alright, should you need further assistance from us, just please report back here and we will be happy to help/assist! :+1:

Best regards,
Agus Utomo

Only had to restart DevKinsta and Docker once in the last 4 or 5 days or so. Been leaving my system on the whole time too. I’ve left it at 30 minutes, no other change, and it’s way better. I think you can close this issue. It’s resolved.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.