Local site greyed out

Yes, it is still greyed out.

Where can I find this main.log file please?

Thanks for sending that over @jacksheo. Can you please view your config.json for me and check to see if there are any running operations? On Windows think will be somewhere like C:\Users\username\AppData\Roaming\DevKinsta\config.json (The AppData folder is hidden)

I’ve gone over how to clear running operations here but do you see anything there? You can also send that file to me privately so I can share with our Developers.

Thanks for sharing that @jacksheo! So here’s what our devs recommend:

  1. Try manually changing the config.json status for “hostFIle” to “running” and remove the error so that it looks like this:
			"hostFile": {
				"status": "running"
  1. Try manually adding the host record to your hosts file with admin permissions like this (you should at least be able to view your site if you add the host records.
    ): yoursite.local www.yoursite.local
::1 yoursite.local
::1 www.yoursite.local

With those changes, try restarting your PC and running DevKinsta as an Administrator. Hopefully that gets you past the error but please let us know if it does not work.

When I first opened up the host record for editing, it was blank.

After changing both config.json and the host file, it (Devkinsta still grey) still didn’t work.

Sorry, I take that back.

I can access the site directly by entering the URL into the browser.

But Devkinsta still shows the site as greyed out - can’t access from Devkinsta.

This is really odd because it would have to be something in your config.json locking things up.
And restarting your PC didn’t work either?

Are you able to create a brand new site within DevKinsta? Also, if you go to the sites overview, are the other options at the very right grayed out as well?

For example, is the option to rename the site still available?

My test today:

  1. Restarting the PC didn’t help - everything is greyed out.

  2. If I click on the 3 dots, there is only “Delete” option.

  3. I could create a new site - everything works properly.

  4. I noticed that after creating the new site, the host file got changed to the following:

START DEVKINSTA entries test-site.local www.test-site.local
::1 test-site.local
::1 www.test-site.local


  1. config.json has 2 “hostFile” entries

The first one is for jack-sheo (the one I’m having problem with) with status “running”

The second one is for test-site with status “waiting”

I’m not able to access jack-sheo.local when I enter this into the browser now.

I think it is because this site’s entries have been deleted from the hosts file?

Odd, it’s as if it just won’t detect that site for some reason. Can you change that running to “waiting” as well for jack-sheo? That might not fix it either, though.

I was thinking you could just create a new WordPress site in DevKinsta then migrate jack-sheo’s database and files to it since you’re still able to access the actual site when you update your hosts file.

We couldn’t see anything in your config.json that would explain why everything is still greyed out.

These are the steps I took today.

  1. Opened up config.json.

a) Changed status of hostFile (for jack-sheo) from “running” to “waiting”.

b) I noticed that status of hostFile (for test-site) was “waiting”.

  1. Started DevKinsta

a) In DevKinsta, test-site is now greyed out just like jack-sheo

  1. Opened up config.json again

a) Status of hostFile (for jack-sheo) is still “waiting”.

b) But status of hostFile (for test-site) has been changed to:

“hostFile”: {
“status”: “installFailed”,
“error”: {
“code”: “DK0027”

  1. I went to open up the file “hosts”. But it is empty.

Looks like something is making changes to “hosts”?

test-site is now suffering the same fate as jack-sheo

Is there something else I should be looking for?

Even if I migrate (not sure exactly how to do it), the problem will come back.

I have sent the current copy of config.json to you.

Odd, thanks @jacksheo, I will have our developers review this again. And you are definitely running DevKinsta as the administrator, correct?

Hi @jacksheo, I’ve finally been able to reproduce this issue/fix it on my end and here is my theory:

Something on your PC keeps reverting the host file changes that DevKinsta makes. It could be a security application or something malicious, I do not know. You would have to find a way to track when the file is changed/what is changing it. Here’s a relevant question. We can keeep troubleshooting if it turns out it’s DevKinsta deleting the entries for some reason.

How I Reproduced This:

  1. I opened my hosts file then deleted the DEVKINSTA entries block(including the commented lines)
#### START DEVKINSTA entries
all my domains here
#### END DEVKINSTA entries
  1. I completely closed then restarted DevKinsta. All of my sites were now grey.

How I fixed this:

  1. I completely closed DevKinsta
  2. I added the DEVKINSTA block back with my appropriate host entries.
#### START DEVKINSTA entries site.local www.site.local
::1 site.local
::1 www.site.local
#### END DEVKINSTA entries
  1. I opened config.json and changed any host related errors to “running” and deleted the error. There are two places where this change needs to be made for each site. I’ve screenshotted a before and after:


  2. After restarting DevKinsta, I’m able to view the sites like normal again.

So fixing the issue is relatively easy, the hard part is figuring out what process is deleting the host file in the first place. I unfortunately can’t reproduce the randomness of it, that’s why I believe it’s something on your PC that is doing it.

I’m going to discuss a possible built-in solution for DevKinsta to just restore entries on restart with our developers, though. That would at least save you from having to do this manually.

Please let me know if these steps do not work for you or if you figure out what is resetting your hosts file.

Hey Kevin

Yes, your suggested steps allowed me to work on the site again. Thanks!

I tried to read up on process monitor but couldn’t quite figure out how to use it to monitor hosts file.

One thing I noticed:

After I corrected the entries in config.json, the next time I started DevKinsta, config.json would be changed again to what you’ve shown in step 3 (the before) above.

During my 20 mins or so of fiddling, I noticed that the following lines were added into hosts file.

Added by Docker Desktop host.docker.internal gateway.docker.internal

To allow the same kube context to work on the host and the container: kubernetes.docker.internal

End of section

That’s what I’ve observed thus far.

1 Like

Very odd. So yes, I believe you have to edit the hosts file and config.json before starting DevKinsta or else it fails again/rewrites config.json.

I have those same lines added by Docker Desktop in my hosts file as well. but Docker usually only adds those when you initially install it.

No worries about tracking what is doing it, though. Our developers are aware of how we are having to fix this manually and will work on a way to automate this. At least we have a temporary fix for now! Please let me know if anything new develops with this issue!

Hi Kevin!

Hope you have been well.

I just resumed working on the site again today (after a 3 months break).

I’m having the same issues - my site is greyed out in Devkinsta.

Following the steps you listed on 3 Jun (changing config.json, adding entries in hosts file) didn’t work.

After changing config.json, I would get the following error message when I started devkinsta.

How can I fix this pls?


Just to add on:

  1. I added a new test site (test2) in devkinsta successfully. After rebooting the PC (once), this new test site (test2) could still work.

  2. The previous test site (test site) you asked me to create has suffered the same fate as the work site (Jack Sheo) I’m building.

Can’t quite recall how to attach/send config.json file to you

Hi @jacksheo, you would get that popup error if your config.json has syntax errors so missing parentheses or something.

You can click on my name and message me from my profile

You can either screenshot the part of the config.json that you changed or share the file with me and I’ll point out the issues.

Hi Kevin!

I’ve figured out what’s wrong - in the 2nd image of your 3 June post (step 3 - after), there is a comma after the sentence (hostFile) “status”: “running”.

Removing the comma after that solved the problem.

Previously you mentioned about a built-in solution for DevKinsta to just restore entries on restart… any traction with that? :slight_smile:

1 Like

Ah, great catch @jacksheo! I’ve edited the screenshot to remove the comma.

Honestly, we don’t see this issue coming up anymore with the new versions. I think a lot of the changes that have been made to the internal processes makes it so that this error doesn’t occur anymore.

This is definitely on our developers’ radar as far as errors go, though!