Local Wordpress Elementor Global settings bug

Q: Date/Time this occurred (Provide your time zone also)
A: 09/07/2024 13:30 UTC +3

Q: DevKinsta Version
A: DevKinsta version 2.13.2

Q: OS Version
A: Windows 10, 22H2

Q: Docker Desktop Version
A: Docker version 4.31.1

Q: Were any error codes or messages observed? If so, what were they?
A: No error codes

Q: Detailed Description of the Problem
A: I’m using Wordpress as a local and making new site with Elementor plugin enabled. Elementor seems to work, but when I try to change global settings on theme ie. global colours it loads forever and never finishes so I could change them. Already tested all the browsers and even different PC, but the same problem still persists. What can be done to this?

Hello @Elmojoha :wave: Welcome to Kinsta community!

Please open browser console and check for errors when you try to change this. There might be indication into what’s going on. Did you try disabling all plugins except Elementor to test?

Kind regards,
Vladimir M


I got this error while inspecting it after I disabled all other plugins

But I got global colours etc. to work by going straight through settings from the page I’m editing and not going from Wordpress admin page → “Elementor Home” → " Jumpstart your web-creation" → “Global…”.

So it works from another route :slight_smile:

Hi @Elmojoha :wave:

I’ve seen that error often, I’m not 100% sure, but I think it has nothing to do with the issue you described. I’m glad you found a workaround. One other route I can suggest is enabling Debug Log. Troubleshooting - Logs and Debugging - Kinsta® Docs

If you see allocated memory errors, check your wp-config.php and if there’s define(‘WP_MEMORY_LIMIT’, ‘64M’); change it to 256MB. If there’s no define for memory limit, try adding one and set it to 256M.

At this moment, we’re guessing because the real cause remains unknown. Let me know how it goes.

Kind regards