Persistent DK0006 (Docker Images) Error Message

Q: Date/Time this occurred (Provide your time zone also)
A: Oct 4, 2023 8AM EST (began Aug 23, 2023 after period of using DevKinsta on a different computer)

Q: DevKinsta Version
A: 2.11.0

Q: OS Version
A: Mac OS 12.6.3

Q: Docker Desktop Version
A: 4.24.0

Q: Were any error codes or messages observed? If so, what were they?
A: DK0006 Couldn’t download Docker images

Q: Detailed Description of the Problem

  • When I open DevKinsta, it immediately shows the “Starting Docker…” message. I’ve tried having Docker running and closed when starting DevKinsta. If Docker is closed it opens almost as soon as that message appears. If Docker is already open, nothing appears to be happening.
  • “Starting Docker…” stays on screen for nearly 10 minutes before the error appears.
  • I’ve tried restarting DevKinsta and reinstalling DevKinsta and still have the same issue.
  • This does not happen on my desktop computer at work (Mac OS 12.6.6). Only my laptop (Mac OS 12.6.3).
  • I do not have any firewalls active on my computer (per forum report).
  • I have tried deleting prior DevKinsta containers when the issue began and Docker shows that none have been created since I deleted them.

Hey @Infantree, welcome to Kinsta Community!

:thinking: Can you please try to run the following command via terminal when both DevKinsta and Docker are entirely closed?

sudo ln -s "$HOME/.docker/run/docker.sock" /var/run/docker.sock

Once done, try to open DevKinsta as usual.


That did it! I ended up with another error that was resolved with other threads. Thank you so much!

Glad to have helped!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.