Pushing from local to Kinsta Site > Development does not upload all files

I downloaded one of our websites using DevKinsta, made some WordPress theme updates to a new theme, and pushed my updates back to SomeWebsite > Development. Several of my directories and files did not get uploaded to Kinsta using DevKinsta. Some of these include


I tried the upload multiple times and it completes with no errors. However, these files are not on the server. I’m only pushing up the theme files, and not the full file system and database as they are combined close to 70Gb. I was super jazzed on DevKinsta in the beginning, but it’s turning into a nightmare to work with at this point. Any suggestion would be much appreciated!
Operating System: Windows 10 Pro using WSL2

Hi @coloradodev, thanks for reaching out!
Can you please walk me through your process a bit?
Are you using the “Push Changes to Kinsta” option then selecting a single theme folder?
If so does the “Local” file size reflect the actual size of that theme directory (including the files/directories that aren’t making it to Kinsta)?

The process just uses rsync, so I’m curious as to why that isn’t working here. Is it a particularly large number of files? Please feel free to share more info with me privately if you can.

Upon further testing, I discovered that this only happens when pushing partial file structures, such as just the wp-content/themes/some-theme directory. Pushing the entire file system added all of the missing files and folders. The fact this happens on multiple sites, on multiple machines, makes me think this might be a bug with DevKinsta. Happy to provide more details if it helps.

Thanks for all the details @coloradodev, I’m going to do some testing for this with my own site before the weekend and get back to you next week. I’ll definitely escalate this to the developers since it’s a big deal if it’s affecting everyone.

Okay, this is confirmed with Windows 10 Pro (I was able to reproduce a similar issue). Our devs will work on this before the upcoming release. We’ll update this thread/the release notes once the issue is resolved.

Hello @coloradodev :wave:

I would like to inform you that we’ve just released version 2.9.0 of DevKinsta as announced here .

I’ve also just upgraded my DevKinsta from 2.8.0 to 2.9.0 version (Note: I’m on Linux laptop - based on Ubuntu 18.04.5).
After that I tried to reproduce the reported issue by pushing/uploading partial sub-folder (and its files/sub-folders) from my local site in DevKinsta to my Staging site on Kinsta server.

Once completed, I then compared the uploaded subfolder (and its files/sub-folders) on both my local site and on the server side, and they all looked the same (so far I didn’t see any missing files/sub-folders).

Could you please try to re-test the same from your local end (Windows 10 Pro + WSL2) with this new DevKinsta 2.9.0, and see if the issue resolved now?