Receiving error DK0066 Failed to import database dump

When trying to push from DevKinsta Local to Staging I receive an error “DK0066 Failed to import database dump”. Both my local site, and staging site seem to be working fine and have no DB errors. I have spoken with MyKinsta support and had them look into things, they found no issues. We then looked at the Dev Kinsta main.log file and found references to DK0066, but the representative did not know how to help me further and suggested I submit a comment in this forum. Please let me know how to proceed.

operating system
macOS Monterey 12.3

Docker Desktop
4.19.0 (106363)

Dev Kinsta
Version 2.10.0 (

Hello @wearegearlocs :wave: welcome to DevKinsta community!

Thank you for reaching us out!
That DK0066 error usually means that DevKinsta was unable to import the local database dump into your MyKinsta site’s database.

If you and our support engineer have checked and made sure already that there’s no database error/issue on the server (Staging) side - no DB tables corruption, etc., and that’s working properly, then I suspect there’s an issue somewhere in the database itself (that has been dumped from your local computer) perhaps - such as for example: in that dumped database, there’s such SQL statement(s) that might require SUPER /ROOT USER access/permission to execute any specific SQL command(s) which then would prevent such operation to be executed.
(Note that users don’t have SUPER/ROOT USER access permission on the server environment).

Please check your main.log file (open it with your local text editor) and search/locate for DK0066 and see if it’s showing errors something like this:

Access denied; you need (at least one of) the SUPER, SET USER privilege(s) for this operation

and also please check there if there’s such SQL command specified/executed in your local Database with something like DEFINER thing (that uses root ).

If that so, you would need to remove those in your database/sql statements (as those would be causing the error/access denied as mentioned above) - and you may want to work with your web developers/programmers to help you with that (as it’s web development related issue instead of DevKinsta or server side issue).

Hope that helps! :smiley:


In my log file I do see a couple references to “Access denied; you need (at least one of) the SUPER, SET USER privilege(s) for this operation”. Unfortunately I’m not sure how to resolve this and I do not have access to a developer other than myself for additional help. Can you please provide further assistance? I also am not sure what would have caused this error to appear recently. I have been successfully making local changes and deployments to staging for many months, and am not aware of any changes that were out of the ordinary.

Heya there! :smiley:

Yeah that error message:
Access denied; you need (at least one of) the SUPER, SET USER privilege(s) for this operation

seems to be due to the DEFINER syntax (that uses root / super user) in your SQL statements perhaps .

I’m not sure either what changes you’ve made on your local site recently - if it’s only the site’s files or along with the Database’s contents as well (not sure either if any of your plugins or theme that might have been updated recently would be causing it).

Perhaps you may want to try to push the changes from your local site (DevKinsta) to your Staging server and only push the files (without or un-check the Database) ? See if that will work fine (without Database).

After that please try to push the same local site to your Staging server, and this time try to push only the Database, and see if it will work (or if it will be showing the same “Access denied” error message in the main.log ?)
In case it’s still showing that same error message when pushing the database only, then there might be something defined in your database’s structure that’s causing the error perhaps (which requires root or Super user thing to execute that specific SQL statements/commands).
If that’s the case, you may require to check further and discuss this with professional web developers/programmers - as we won’t be able to provide support for such coding nor DB SQL syntax related issues).

I would also suggest perhaps try to export your local database into .sql file using the Adminer DB tool . Once exported to your local folder on your computer, you can try to import that .sql file to your Staging server using phpMyAdmin tool , and see if the exported .sql database file can be exported properly to your database server on your staging server?


Ok, I did try pushing just the files and that worked. Then tried pushing just the database and received the same error. As another test I created a new devkinsta site and did a PULL from staging which would have given me the last instance of a successful deployment. The pull was successful, so I immediately tried pushing it back up to staging and now received a different error DK0029 “can’t create mysql dump”. Nothing was changed locally before attempting to push to staging.

Thank you for your reply and update!
Alright so there’s no issue with your site’s files it seems but only with the Database most likely.

Interesting! so the site pull from Staging (which of your staging site by the way?) server to DevKinsta (local site) was successful - and after the site was pulled, were you able to access the local site and it showed the same as your Staging site, and no errors at all?
And after that, when you pushed that local site immediately back to that same Staging site/server, you got a different error DK0029 “can’t create mysql dump” :thinking:
Could you please send me (DM) the latest main.log file which related to this new error code, if it will tell further information/details in it?


Yes, that is correct. After the pull from staging to local the site loads and displays correctly in the browser, but as soon as I try to push it back up to staging I get the error DK0029. I’ve attached the main.log file for you to review.

Also, here’s the snippet from the log file with the DK0029 error.

Error - DK0029: MYSQL_DUMP_COMMON: Error (2): mysqldump: Got error: 1449: The user specified as a definer (‘chiptheorygamesv2’@‘localhost’) does not exist when using LOCK TABLES

Hi @wearegearlocs ,
I believe that your database might contain some views that state a definer. Could you please open the site page in DevKinsta, click on the ‘Database manager’ button, and check if inside the database of your site you can see any Views? If you find some, open them and see if they contain a definer that states the chiptheorygamesv2 name.