Seeing 404 Error for NGINX on loading local sites

Dev Kinsta has worked for me in the past. Not sure if this is a result of the recent Mac OS X upgrade (Ventura - 13.0.1) conflicting with Dev Kinsta (version 2.9.0).

But when I launch the site or wp-admin, I get an NGINX 404 Not Found error.

Any thoughts on what could be causing this?

I having the same issue and it’s driving me nuts. I’ve tried with ssl and without it. Tried to change nginx configuration but nothings seems to work. It goes stratight to 404 on any site and any address.

It must be related to 2.9.0 in ventura yes…

Same here… Looking for a solution and can’t seem to track one down.

Hello everyone :wave:
@steckinsights (Brian Steck), @Bozabit (Daniel Alvarez Echenagucia), and @Joe_Young
welcome to DevKinsta community!

Thank you for reporting this issue.
I’m not able to reproduce this issue on my end, cause I don’t have Mac machine here, and only have Linux laptop (based on Bionic/Ubuntu 18.04.5) - and I’ve just replaced/upgraded the DevKinsta from 2.8.0 to 2.9.0 version.

So far the previous sites I created (as well as new site I created just now) are all working/loading just fine (I don’t get NGINX 404 Not found error) with the current DevKinsta 2.9.0 on my Linux laptop.

I will report and ask my colleague and internal dev team to test this DevKinsta 2.9.0 on Mac OS Ventura, and see if they can replicate the same issue with it.
We will update you all again here as soon as we have more information/update from them.


Hello again: @steckinsights (Brian Steck), @Bozabit (Daniel Alvarez Echenagucia), and @Joe_Young :smiley:

1 of our DevKinsta devs has just tested to reproduce this reported issue on his Mac OS Ventura (and DevKinsta 2.9.0), and he was able to create a new site with it without any issues (didn’t get NGINX 404 error when he accessed that site), and this doesn’t look like an OS related issue as per his test.

To check and investigate this further, could you please provide (copy-paste) the contents of your:

  1. /etc/hosts file
    ( at least for the DevKinsta section, between “#### START DEVKINSTA entries” and “#### END DEVKINSTA entries” )

  2. nginx config file for the particular site in question (in the ~/DevKinsta/nginx_sites/the-site-name.conf file)

Also, could you please clarify if this 404 error not found happening only on your pre-existing sites (created before DevKinsta 2.9.0), or if it’s also happening to the new created sites as well?


I can verify that the issue seems to be exclusive to existing sites before the upgrade. New sites seem to work fine. Meaning I can create a new site and everything works as expected.

I will look into the files you are suggesting and post my findings

New sites and pre-existing sites for me…

It happens with all sites… an sending just one ngix config as they are all the same

Here is the ngix config…

Thank you both for your replies. @Bozabit , that Nginx configuration would explain why the site is returning 404. Can you please make a safe copy of the current Nginx conf file and then replace the original with the following:

server {
  set $site_name tubrica-81-version;
  set $php_path devkinsta_fpm:9004;

  listen 80;
  listen [::]:80;
  listen 443 ssl http2;
  listen [::]:443 ssl http2;


  ssl_certificate /www/kinsta/ssl/;
  ssl_certificate_key /www/kinsta/ssl/;

  server_name *;
  access_log   /www/kinsta/logs/tubrica-81-version_access.log main;
  error_log    /www/kinsta/logs/tubrica-81-version_error.log;

  root /www/kinsta/public/tubrica-81-version;
  index index.php index.html;

  include multisite_subdir.conf;

  location / {
      try_files $uri $uri/ /index.php?$args;

  location ~ \.php$ {
      fastcgi_split_path_info ^(.+?\.php)(/.*)$;
      if (!-f $document_root$fastcgi_script_name) {
        return 404;
      include fastcgi_params;
      fastcgi_param PHP_ADMIN_VALUE "";
      fastcgi_intercept_errors on;
      fastcgi_pass $php_path;
      fastcgi_param  SCRIPT_FILENAME $document_root$fastcgi_script_name;

I’ll report back to our devs to investigate why the Nginx config has been edited in the first place.

It worked… Yes I saw tht 404 as well but I know litle to nothing about nginx and all the other were exactly the same.

That is good news @Bozabit, thank you for sharing. Closing DevKinsta, removing the Nginx config file, and then starting DevKinsta again should also regenerate the file properly.



1 Like

I can verify that by simply deleting the nginx_sites/site-name.conf file and restarting devKinsta fixed my issue.

Thanks for the help! :facepunch:t3::v:t3:

1 Like

Great to hear that workaround helps to fix the issue @Joe_Young ! :clap:
so I think that’s the solution for this issue that we can follow right now :+1:

We’ve also reported this case to our internal devs to check/investigate further and to see if we can find the root cause for it (why the NGINX site config file has been modified/edited in the first place).

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.