404 whenever I open any sites

Q: Date/Time this occurred (Provide your time zone also)
A: For hours!

Q: DevKinsta Version
**A:**Version 2.9.0 (

Q: OS Version
A: Monterey

Q: Docker Desktop Version
A: 4.15.0 (93002)

Q: Were any error codes or messages observed? If so, what were they?
A: 404 in Browser

Q: Detailed Description of the Problem
A: I can’t open any of my sites. It’s all of a sudden as I’ve used DevKinsta before and was able to open site.

I’ve uninstalled and reinstalled Docker / DevKinsta more times than I can count and still not getting to my sites. The config file for one of the sites is below. They all look similar to

Hi Alicia! @WPwithHeart :wave:

Would you be able to close DevKinsta, remove the NGINX site configuration file for the affected sites, and restart DevKinsta, then post the regenerated version of the NGINX configuration file for comparison?

Reference: Seeing 404 Error for NGINX on loading local sites - #11 by Alessandro

Best regards,

Hi ZachE,

Sorry about the long delay between posts had to handle some time sensitive web work.

So, here’s what I’ve done:

  1. Closed Kinsta

  2. Updated Docker to 4.16.1 (95567)

  3. Opened Kinsta

  4. Started a site and still get 404 when I try to access it or any of the sites.

Here’s my file:

Hi Alicia :wave:

Thank you for your reply.
Can you please close your DevKinsta completely (not only minimized, but fully shutdown), and once fully closed/shutdown, please open the terminal program on your Mac, then go to this sub-folder with this command:
cd ~/DevKinsta/nginx_sites

and then, please remove / delete that sub-pacific-solar.conf file under that sub-folder mentioned above (or you can simply just rename it to something else with something like: mv sub-pacific-solar.conf sub-pacific-solar.conf.old ).

After that, please try to open DevKinsta again, and it should re-generate the new .conf file of that particular site and it should work after that.

Please let us know again if you’re still experiencing any issue with it.


Now I’m getting " Error establishing a database connection".

The file looks different, however…

Hey @WPwithHeart ,
Can you please test the MySQL connection by doing the following:

1.Open Docker and click on the three dots menu of the devkinsta_db container
2.Click on Open in terminal

Once there, use this command being sure to update PASSWORD, DATABASEPORT and DATABASENAME with those you see inside DevKinsta


What does the terminal reply with?



ERROR 1049 (42000): Unknown database ‘Sun_Pacific_Solar’

Hi Alicia,

That error ERROR 1049 (42000): Unknown database ‘Sun_Pacific_Solar’ means that the database in question ( Sun_Pacific_Solar ) is unknown/not available (does not exist) on your local computer (inside the devkinsta_db container). And that might be the reason why you’re getting: " Error establishing a database connection".

You can try to run the following mysql command line in that same devkinsta_db terminal (to check if the database in question does exist/available in that container or not) - and be sure to update the PASSWORD and DATABASEPORT with those you see inside your DevKinsta :

mysql -u root -pPASSWORD -h localhost -PDATABASEPORT -e “show databases;”

that will show all databases you have inside that devkinsta_db container.
See if you notice the proper database name that should be used by that sub-pacific-solar.local site ?


Hi Agus,

I had a database. It’s gone, somehow.

I’ve moved back to Local by Flywheel.

Sorry. Can’t risk losing sites.

Hello @WPwithHeart ,
Most probably, the database has been removed when Docker has been uninstalled and then reinstalled. While the files of your sites are saved in a standard folder, the databases are stored inside a Docker Volume, uninstalling Docker causes a loss of data.
We’ll be here in case you would like to give this another go in the future :wave: