Some photos not working

Hi there, I have just deployed a simple static site and some of the photos are not working. I deployed to vercel and the photos work, but it’s a commercial site so I removed it so as not the violate their TOS. The photos work locally as well. I have triple checked file paths. Here is the site. Any help is appreciated.

Hey Sara :wave:

When I look at the site with the network console, I can see that three of the images are returning 404 (Not found) errors.

Can you confirm those files exist and are named the same in your repository?

Hi there. Yes the images are there and named correctly. When I deploy with vercel it works fine.

Hi @WebChefDev! :wave:

Please make sure to check the file names of the images that are not loading. From the browser console, it appears that the URLs contain ‘%20’, which represents an empty space. To resolve the issue, you can try removing any extra spaces from the file names.

We are also consulting with our developers to determine whether this is an expected behavior or a bug that requires fixing. As soon as we receive an update from our developers, we will inform you.

Best Regards,


I have double checked everything. I do not see the excess characters you mentioned. The site including the images works fine on vercel, which is the same repo that is used in Kinsta:

Thank you

Hi @WebChefDev!

Thank you for your reply! I’d be happy to clarify what my colleague, Adrian, was referring to earlier. We were able to review the public repository you are using to import your static site from. We noticed that it appears the image files that are returning a 404 error have spaces within the file names in the repository.

Would it be possible for you to rename the image files to include hyphens rather than spaces in the file names? For example instead of “file name here.jpg” you may rename the file to "file-name-here.jpg’.

Then, you may redeploy your static site with these updates.

Please let us know if you need any further assistance with renaming the files. We are happy to help!

Best regards

Hi! I have tried that and it worked. Thank you for your clarification and help! Much appreciated. I will be sure to not use spaces in the future, which I don’t typically do.

Thanks again.

Hi @WebChefDev!

Thanks for your reply! I’m glad to hear that renaming the files resolved the issue! Our team is continuing to look into this further though to see why having spaces in the file name would cause this in the first place.

If you do have any questions in the future please don’t hesitate to reach out!

Best regards