Error: This does not seem to be a WordPress installation

Q: Date/Time this occurred (Provide your time zone also)
A: 10/01/2023 / CMT +6

Q: DevKinsta Version
A: Last

Q: OS Version
A: Win 10

Q: Docker Desktop Version
A: Last

Q: Were any error codes or messages observed? If so, what were they?
A: in log file I found error message : This does not seem to be a WordPress installation

Q: Detailed Description of the Problem
A: Trying to create new site or customized site but got several times message that something bad. I deleted DB contaner, the message disappeared, but installation hunged and not finishing as shown on first screenshot

when trying to create new site, the same message apearing again - “something bad happened” as shown in second screenshot

Hello @Bach :wave: welcome to DevKinsta community!

That “Something bad happened” error on the 2nd step (as shown on the screenshot) seems to be when processing the “Creating MySQL database” process.

To clarify, you mentioned that you deleted DB container, I assumed you did delete the “devkinsta_db” container in your Docker desktop, right?
After you deleted that DB container, have you also tried to close and quite from DevKinsta completely (and made sure it’s not running in the background) and, after that then re-loaded/re-opened it, so the “devkinsta_db” container can be re-created? (similar to what I suggested in the other thread here)


Hi Agus! Thank you for your reply.!
Yes, I have done all steps as you suggested in similar cases. After re-creating db-container it is going to install WP and hanging as shown on 1st screenshot. Error message as per topic head.
When creating another (second) site in the same environment the message “something bad” happens for it (screenshot 2)

Hey @Bach, I’d like to review the application error log, can you please send me the main.log file via DM?
You can find it by clicking on the question mark icon at the bottom left corner of DevKinsta and then on Reveal log file in File Manager.



Thank you for the log @Bach, please try the following:

  1. Close DevKinsta and be sure it’s entirely closed and not just minimised
  2. Open Docker
  3. Delete all the devkinsta containers by clicking on the bin icon
  4. Start DevKinsta again
  5. Add a new site

While in Docker, be sure to delete only the containers and nothing more, by doing so there will be no data loss.



Hi Alessandro! Done, I sent main.log in direct message tou you.
By the way, I found another error when trying get access to DB via Adminer.
On screenshot below there is a message
SQLSTATE[HY000] [1130] Host ‘’ is not allowed to connect to this MariaDB server

This error and the one happening during the site creation should go away by following the steps listed above :crossed_fingers:

I tried etherything but it is not working

Hi Bach :slight_smile:

Thank you for your reply.
May we know what is your Windows 10 version exactly? (if it’s Home edition or Pro edition)?
I’m also wondering if there’s such local firewall , anti virus or something else on your Windows 10 machine that might be causing this issue (still unsure though) - and if any of them can be disabled temporarily and re-test.

Also have you tried to completely uninstall both DevKinsta and Docker desktop programs, and re-installed them from scratch and re-test? So far I couldn’t reproduce this issue on my Windows 10 pro machine (and note that I don’t use WSL2 based engine in the Docker desktop - General settings).


hi Agus,
I reinstalled both Docker and DevKinsta at least four times since the error, with no result.
As I remeber, I marked to use WSL2 as recommended during installation and for hyper-v

winver = Windows 10 Pro Russian (maybe this is a reason it is not working because of sanctions :slightly_smiling_face: )
macAffee safe connect and windows defender as antiviruses
details of OS:
Windows 10 Pro 64-bit x64
Version: 22H2
build - 19045.2486
Windows Feature Experience Pack 120.2212.4190.0

my last try - going to reinstall docker without wsl2 checkbox

great: passed to next error DK0005

ooops: returned to the same situation shown in the screenshots at the beginning of the topic
But main.log contains more errors, which i sent in DM to you for info

Hello again Bach :wave:

Thank you for your reply/update. I don’t think it’s related to your Windows 10 Pro Russian version at all :smiley:
I got your main.log file as well and have checked it.
As can see from that log file you sent, I noticed the following lines (when the DevKinsta was trying to setup new site qwertynew database )

[2023-01-13 05:10:30.289] [info]  [containerExec] Command 'mysql -u root -p****** -e "create database qwertynew;"' on devkinsta_db finished with exit code 1
[2023-01-13 05:10:30.297] [info]  [ProgressIndicator] { isFailed: false, isOpen: false }
[2023-01-13 05:10:30.290] [error] [ipcMainStep] Error in operation SITE_CREATION, step database: Error: Error (1): UERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

that seems to be related to the wrong password issue for that root DB user, which could be the reason why it stopped on that 2nd step “Something bad happened” (when it was trying to create MySQL database) - as shown on your screenshot initially.

Could you please open your Docker desktop, and there on the Containers section, please click that container name devkinsta_db , and then click on the “Inspect” tab ?
After that, check on the Environment → MYSQL_ROOT_PASSWORD section and note/copy that MySQL root password shown there.

Once noted/copied (let’s say on notepad text editor for example), back to that Docker Desktop (same devkinsta_db container) and click on the “Terminal” tab.
There, please perform this mysql command line manually (no space after -p and replace YOURMYSQLROOTPASS with the actual password you got from that Inspect tab above) :

mysql -u root -pYOURMYSQLROOTPASS -e “create database qwertynewtest;”

and see if it returns any error?

Or you may also want to simply try to login to that mysql with root user, with this command line:

mysql -u root -p

you will then be prompted to enter the password, and see if you can login with the MYSQL Root Password you got from the Inspect tab above.

If it’s not working (and you get ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)), then it’s something with the ROOT MYSQL password related issue set in that DB container.

I also have also checked in our internal communication/history for similar error above, and 1 of our DevKinsta developers recently mentioned that the wrong password issue still happens quite frequently.

There he suggested to stop DevKinsta, removing all the containers and starting DevKinsta again (but I think you have done this and no effect still).
And he also then mentioned there, if that still didn’t work, he suggested to back up everything (sites and databases), clean up DevKinsta completely (all folders, containers, network, volumes), and then start from scratch and recover from the backups. But since you don’t have any sites yet, you don’t have to perform any backup/restore.

So if it’s still not working (and you’re not able to connect to that MySQL DB with that root mysql password), I think you may want to double check and make sure to remove and clean-up DevKinsta completely (also remove any folders/data related to it, all containers, network volumes, etc.), may also want to remove/delete anything inside these folders (e.g.: C:\Users\youruseraccount\AppData\Roaming\DevKinsta , and C:\Users\youruseraccount\DevKinsta ) and start from scratch.