Stuck on Updating site WordPress configurations

After a restart I’m continually stuck at this point of the start-up. I’ve quit and restart the program a few times and get to the same point.

Docker containers all seem ok.

I’ve checked the logs and errors appear to be related to auth:

[2023-03-30 15:51:28.820] [error] [user/token] failed to decrypt user token. Error while decrypting the ciphertext provided to safeStorage.decryptString. Ciphertext does not appear to be encrypted.
[2023-03-30 15:34:01.824] [error] [usePhpVersions] failed to load php version list Error: ApiResponseError - DK0011: API_RESPONSE_ERROR_COMMON
[2023-03-30 15:35:31.122] [error] {
  message: 'Request failed with status code 401',
  name: 'Error',
  stack: 'Error: Request failed with status code 401\n' +
    '    at module.exports (file:///Applications/\n' +
    '    at module.exports (file:///Applications/\n' +
    '    at XMLHttpRequest.onloadend (file:///Applications/',
  config: {
    url: '',
    headers: { Accept: 'application/json, text/plain, */*', Authorization: '' },

Because the application doesn’t start-up I can’t logout or in again (if that’s an option). I’ve tried normal quit and force quit but I get the same.

Any ideas?


Hey @PeteWard , welcome to DevKinsta Community!
Can you please send me a copy of your main.log file via DM? You can find it by clicking on the Help menu of DevKinsta and then on Reveal log file.
We’d like to give a look at it and help you find the culprit.


Thank you for sharing the log file @PeteWard.
Yes, the issue seems to be related to the token used by your user. Let’s do this test, open Finder > Go > Go to folder (or use the SHIFT, COMMAND, G shortcut) and move to ~/Library/Application Support/Devkinsta inside this folder you should see a config.json.

  1. Make a backup of this file for safekeeping
  2. Make sure that DevKinsta is entirely closed
  3. Edit the original file with a text editor and scroll all the way down to the bottom, you should see a user block like the following:
"user": {
		"email": "",
		"firstName": "yourName",
		"lastName": "yourLastname",
		"token": "randomString"
  1. Proceed to delete this user block and save the file
  2. Try to open DevKinsta again


Hi @Alessandro ,

Thanks for getting back to me.

I’ve removed that block from the file, saved, and restarted DevKinsta, but sadly I get the same thing - still stuck on Updating site WordPress configurations.

I will re-send you the log file but this time there are no errors, everything seems fine from a logs perspective…

Hi @PeteWard,
the log doesn’t show a proper error but it seems to be getting stuck when start using the FPM container, let’s give this a try:

  1. Be sure that DevKinsta is entirely closed
  2. Open Docker, move to the Containers tab at the left, and delete all containers. (Be sure to don’t touch the Volumes as they are the ones storing data like the databases etc)
  3. Close Docker
  4. Start DevKinsta again


Hi @Alessandro ,

I’ve tried this a couple of times.

After clearing the containers, on first load I get stuck on Updating site URLs…
If I restart I’m then stuck in the same place of Updating site Wordpress configurations

In both cases, the last message in the logs is:

[2023-03-31 09:44:54.481] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container

If I remove both of the entries in my sites[] in the config.json file then DevKinsta loads up in an empty state. But if either of my two sites are present in that yaml file it won’t load.

Should I try deleting the FPM volume?


Unfortunately without a proper error, I think that the last thing we can do is backup the data and then delete containers, volumes, and DevKinsta folders from the User folder and Library/Application Support, and then start DevKinsta.

Do you have a previous backup of the local sites or you need to make one?

OK no problem,

It’s not a huge loss.

I’ll try a couple more things here to see if I can get it working then I’ll delete and restart.

Thanks for your help.

Well I deleted everything - containers, volumes, even images. Deleted the DevKinsta home folder and libraries.

I tried to install a new site and it gets stuck immediately on Installing Wordpress and just sits there. No errors in the logs, just stuck. I’ve tried it 3 times now and getting nowhere.

Very weird…

@PeteWard that’s odd indeed, do you mind sending me the latest main.log?