Something bad happened 🤔

When I want to create a new page, after configuring NGINX, the following message appears, something bad happened. The installation process is then not continued.
The log says: The command “docker” is either misspelled or could not be found.

How can I fix the error?

Hello @hadilo welcome to DevKinsta Community!

Can you please send me a copy of your main.log file via DM? You can find it by clicking on the question mark icon at the bottom left corner of DevKinsta and then on Reveal log file in File Manager.
We’d like to give a look at it and help you find the culprit.


main.log (1019.8 KB)

Thank you for sharing the log @hadilo, it looks like for some reason the root password for the database used by DevKinsta isn’t recognised.
Can you please try to close DevKinsta entirely, open Docker, move to the Containers tab and delete all the containers and then retry to use DevKinsta?
Be sure to only delete those and not Volumes as otherwise this will cause data loss.


main.log (17.6 KB)
Unfortunately, the error still occurs. But now only at 20%

Hello @hadilo :wave:

I’ve checked your latest main.log file and there I still noticed this error message:

[2023-02-23 16:15:31.371] [info] [containerExec] Command ‘mysql -u root -p****** -e “create database test001;”’ on devkinsta_db finished with exit code 1
[2023-02-23 16:15:31.372] [error] [ipcMainStep] Error in operation SITE_CREATION, step database: Error: Error (1): UERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

Could you please open your Docker desktop, and move to the Containers tab, then please click the container name devkinsta_db , and then click on the “Inspect” tab ?
After that, check on the Environment → MYSQL_ROOT_PASSWORD section and note/write that MySQL root password shown there to your notepad or text editor for example.

Once noted, please go back to your Docker Desktop (same devkinsta_db container) and click on the “Terminal” tab.
There, please perform this mysql command line manually (no space after -p and replace the YOURMYSQLROOTPASS with the actual password you noted/got from that “Inspect” tab above) :

mysql -u root -pYOURMYSQLROOTPASS -e “create database test001;”

and see if it returns any error?

Or you may also want to simply try to login to the mysql with root user, with this command line:

mysql -u root -p

you will be prompted to enter the password, and see if you can login with the MYSQL Root Password you noted/got from the Inspect tab above.

If it’s not working (and you get ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)), then it’s something with the ROOT MYSQL password related issue set in that DB container (which would prevent DevKinsta to create/manage databases in that DB container).

You may want once again close and shutdown DevKinsta completely (not just minimized) and remove/delete only the devkinsta_db container from your Docker desktop, and retry .

If it’s still not working, I’m wondering if you have any existing sites created in your DevKinsta already? or it’s just a brand new installation (and no local sites yet)?

In case you don’t have any local sites created yet in your DevKinsta - and the mysql root password is still not working (not able to connect to the MySQL DB with the root mysql password as explained above), then I think you may want to consider to remove and clean-up DevKinsta completely (and remove any folders/data related to it, all containers, network volumes, etc.), may also want to remove/delete anything inside these folders (e.g.: C:\Users\hadil\AppData\Roaming\DevKinsta , and C:\Users\hadil\DevKinsta ) and start from scratch to re-install DevKinsta.