"This site can’t be reached", but adminer is still accessible

@devstagr, please check if this warning appears when launching Docker Desktop. If it does, click “Re-apply configurations” to allow DevKinsta to initialize. See the screenshot below for reference:

That notification already appeared a couple of days ago - already clicked on it to reapply

@devstagr I’m not sure why but maybe try installing back the previous version, 4.26.1, and make sure you choose the correct Docker Desktop installer for your Mac based on its processor - Docker Desktop release notes | Docker Docs

I’m on 4.26.1 already… Maybe I’ll try upgrading to 4.27.1?

No dice with 4.27.1 either… Wonder whether to go way back to what I originally started on 4.9.1 and see how that goes

Alright, going back to docker 4.9.1 got devkinsta started again and detecting docker so I now have the port number.

However, now I’m getting sudo: not found (tried sudo, Sudo, SUDO…)

Any ideas?

Hi @devstagr!

Thank you for your reply, and thank you for providing those details. I do see from the main.log file you shared with me that DevKinsta was originally reporting “[2024-02-01 11:12:32.630] [error] Error - DK0003: DOCKER_INSTALL_COMMON_ERROR: Docker isn’t installed”

It is interesting that downgrading back to Docker 4.9.1 allows DevKinsta to launch. At the moment I’m not able to replicate any issue with the latest Docker version 4.27.1. I will be looking into this further with our team to see what might be causing this issue on your end with newer versions of Docker.

Regarding the sudo issue, may I have details about how and where you are trying to run sudo and seeing this error?

We look forward to hearing back from you!

Navigating to docker, clicking on the terminal button

Terminal launches, I type in sudo -su grace and it errors, as below


Thank you for your reply, and sharing those screenshots! By default sudo is not installed in the image. If you’d like to install it manually you may do so by running “apk add sudo”. Please note however that if the image is updated, or redeployed then manually installed packages may need to be reinstalled.

We are continuing to look into the Docker issue to see why DevKinsta is having difficulty locating the Docker installation when you are running an up to date version of Docker. We will be following up as soon as possible once we have more details to share.

Please let us know if you do have any questions in the meantime!

@devstagr Can you try without sudo? Try doing ’ su grace ’ instead. Let me know how it goes.

su grace works, but then command wp is not found - presuming that wp cli doesn’t come as standard inside of these docker templates?

Tried to install it via this guide: Installing – WP-CLI – WordPress.org (after firstly running apk add php, successfully installing php 8.1.22)

But end up with this error

PHP Fatal error: Uncaught Error: Class "Phar" not found in /wp-cli.phar:3

Oh please access the terminal inside the devkinsta_fpm container. As shown on my previous screenshot.

Success: Made 0 replacements.

On the command

wp search-replace 'https://instancename.local:49729' 'https://instancename.local'

(also tried with http://, and without https:// all together)

From what I can see in the wp_options db table, the site url doesn’t include the port

On a side note, been trying to start a new instance from scratch, but keep running into this error :confused: - So looks like no working instance anywhere for me still.

Hi @devstagr!

I’m sorry to see that you are having difficulty with creating a new site as well using DevKinsta. We certainly want to get to the bottom of what’s causing these issues to occur.

I am going to be escalating this with our development team to help further investigate into what’s causing the Docker issue, and this current issue where you are unable to create a site.

Would it be possible for you to share an updated copy of the main.log file so we may review the error occurring during this site creation please? That will help in our investigation.

We look forward to hearing from you!

Our engineers have reviewed the issue and they are not able to say with any certainty what is causing it. However, one of the theories is that your system doesn’t have access to docker commands.

To test this, please try running which docker command. If the command doesn’t work, you should review this thread for a possible solution: Docker not found when freshly installed on Mac · Issue #6793 · docker/for-mac · GitHub

If the command does work, then you can try:

  • running Docker as System user
  • Enabling default docker socket
  • Having a look at permissions

But before trying those, please check if the which docker command works.

Let us know if the above helps.

Presuming this means it works


  • running Docker as System user
  • Enabling default docker socket
  • Having a look at permissions

This is a little above my knowledge level as I’ve never really set up a docker container before - (hence using DevKinsta…) - could you walk me through this a little?

Appreciate all the help!

Our engineers are still suspecting some sort of permissions issue.

You could also try running e.g. docker --version just to see if the user you’re logged in with has the permission to execute docker from the CLI.

Also, can you please recheck and make sure that in Advanced Docker Desktop settings everything is set as per this screenshot:

Kind regards

grace@Graces-MacBook-Pro public % docker --version
Docker version 25.0.2, build 29cf629

Yep that command works.

Have re-updated to the latest version of docker and set the settings to mimic what you’ve got there, and something has happened…

Will report back

Thank you for the update, @devstagr! We look forward to hearing back from you! :slight_smile:

Going through those config updates in docker did /something/ as now my local site runs on domain.local without ports, so I presume that fixed the routing issue.

As this was taking too long to sort though, in the meantime I ended up taking the other users advice in this thread and user LocalWP to set up a dev environment (https://localwp.com/)

This not only works, but performs miles and miles faster than DevKinsta has been for the last while (0.5s page loads vs 20-30 seconds) - related to an issue I reported a long time ago but never actually got properly resolved.

Because of these changes though a lot of assets/elements in DevKinsta environment have been purged/migrated to the LocalWP env, so the Kinsta one is in a bit of a sorry state now (my own fault!) - but still loads slowly…

I’m probably going to switch to LocalWP at this point because it works, and it’s miles faster when it comes to performance.

I don’t imagine this is the end of my DevKinsta journey as we host everything with Kinsta, but I feel very unenthused to continue trying to use it for the time being, now knowing that the performance issues are related to the software and not the specs of my laptop, and equally how long this took to get things half resolved. Hopefully at some point in the future these issues can be fixed?