"This site can’t be reached", but adminer is still accessible

Been trying to fathom this one, but it has been an issue since I updated from Monterey to Sonoma just over a week ago.

Environment seems to start, and this is shown by some happy containers inside of docker

But, for whatever reason, the local routing seems to be invalid as my usual site.local domain is returning a ‘This site can’t be reached’ error. I’m wondering if the local ports/certs got reset somehow in the upgrade?

I have tried changing the TLD inside of devkinsta in an effort to refresh those but to no avail.

Have already done the obvious, restart devkinsta, restart docker, restart laptop.

Hello devstagr :wave:

I’m sorry to hear you’re having troubles using DevKinsta.

If you’re certain that the issue happened after the OS update, it’s possible that some aspect of has changed with the update.

The first thing I would advise checking is the hosts file. Check if there are entries for your local sites that are pointing to ::1 or For example:

::1 mysite.local
::1 www.mysite.local mysite.local www.mysite.local

If you check the hosts file and it looks good, but you still have the issue, please provide:

  • the exact OS version
  • Docker version
  • DevKinsta version

Kind regards!

Seems to be in there…

OS: 14.2.1
Docker: 4.9.1
DevKinsta: 2.12.1

# Host Database
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
## localhost broadcasthost
::1 localhost
# Added by Docker Desktop
# To allow the same kube context to work on the host and the container: kubernetes.docker.internal
# End of section
#### START DEVKINSTA entries site.local www.site.local
::1 site.local
::1 www.site.local
#### END DEVKINSTA entries

The docker version is a bit out of date. I use 4.26.1 and I haven’t been able to replicate this issue.

If applicable, could you try updating Docker to 4.26.1 or 4;27 to test?

Kind regards

Hmmm - it says I’m up to date, and the ‘check for updates’ button is disabled. Will try downloading a new version manually

Same problem here. All websites are unreachable since the 2.13 update.
Docker is up to date (4.27). DevKinsta containers are all 1.3.5.
Nothing wrong in /etc/hosts. I’m on MacOS 14.3.

Now devkinsta tries to load websites via a port, ie : https://mywebsite.local:51209
This is very problematic for lots of us, I litterally can’t work :frowning:

The error displayed is : PR_CONNECT_RESET_ERROR and then after a reload PR_END_OF_FILE_ERROR

Yea, same with the port issue. Reinstalled docker and no dice. And yes, equally cannot work right now

I’ve also tried to create a new personnalized website, but it never ends installation.
No “Wordpress” part in the site détails (to activate WP_DEBUG for example).
Everything is broken…

I think I’ll use LocalWP, I’m tired of devKinsta chaotic development.

I’ve removed entirely DevKinsta and Docker using CleanMyMac to ease the process.
Then reinstalled Docker (v4.26.1, not 4.27), reinstalled DevKinsta (it tooks ages to prepare containers, maybe 20mn).
Creating a new personnalized website works again, but just close DevKinsta and Docker, then restart Docker : it says the config has been changed by a software, and want to apply default config :
If you don’t apply, DevKinsta don’t boot and get stuck at “Updating dockers containers”.
If you apply, DevKinsta starts, but websites are again not reachable…

Still stuck.
Please provide previous working version of DevKinsta 2.12.1 !

Mmmm not tried any of this specifically, but have done a range of installs/uninstalls/downloading new environments, all to no avail and failure to load any sites. Would really appreciate some guidance here as I can’t do my job properly without a local environment… And I’d really rather not have to reset my entire teams workflow because of this


We understand that some of you may be facing a frustrating issue, and we want to assure you that we’re here to help. We’re currently investigating the problem, but unfortunately, we haven’t been able to replicate it on Mac OS Sonoma with the latest version of DesKinsta 2.13.0.

We know how frustrating this can be, but we believe that the issue may be related to the local DNS resolver of the machine rather that the app. If you have added your site’s local domains to the local host file, we kindly request that you try clearing the DNS cache by referring to this link: How to Flush DNS Cache (Windows, Mac, Chrome, Linux).

We also suggest adding a new WP site to refresh the machine’s host file and validating the local DNS by pinging the domain.

Please let us know if the issue persists after trying the above suggested troubleshooting.

Also, to prevent the DevKinsta app from using random open ports to the site, you can uncheck the “Auto Detect” box located in the Port selector section within the DevKinsta settings. Instead, you can set port 80 for HTTP and port 443 for HTTPS. This ensures that the assigned ports remain constant.

Done this, but now running into a different issue…

You can see Docker is installed (and running) in the background. Starting up DevKinsta with Docker closed returns the same result

Thx @Adrian_L for your answer.
I’ve already done what you suggest, but with no success.
Still, removing Docker + DevKinsta, reinstall them, start them, Add 1 site properly with https, but if I close DevKinsta and Docker and restart them, nothing works, like described in first posts…

Anyway, I’ve moved to LocalWP, it’s more complete, stable, powerful and uses 500Mo of RAM where Docker + Devkinsta uses 3Go+…

@devstagr I’m sorry to see that you are now having difficulty with launching DevKinsta. I can imagine this is frustrating, and I understand how important DevKinsta is to your workflow.

I would like to see what is happening during the launch process that is causing DevKinsta not to be able to detect Docker. To do this, I’d like to take a look at the main.log file. Could you please send me a direct message with the main.log file attached? You can locate this file under /Users/username/Library/Logs/DevKinsta

@dw4y I’m sorry to hear that you have moved on to another application. If you would like to give us another chance we are standing by and happy to help. You may also send a copy of the main.log file to me as a direct message and I would be happy to take a look into it to see what errors are occurring if you are interested.

Best regards

Hi Andrew - sent across my log file

Hi @devstagr @dw4y

After trying different versions of DevKinta and Docker Desktop, I believe I think I managed to replicate the issue. It appears that the problem is related to the URL containing a custom port. Even if the “Auto Detect” box in the Port selector section in DevKinsta Settings is unchecked and port 80 and 443 are set for HTTP and HTTPS respectively, the site URL can still have the custom port included when loaded. In this case, it is needed to perform a search and replace in the site’s database to update the URL.

In my case, I was getting the following error message, so I needed to do a search and replace in the database.

I used the Docker Desktop terminal to run Search and Replace in the site’s database using WP CLI. Alternatively, you could also do the search and replace through the Database Manager UI directly in DevKinsta.

Search: https://migrationproject.local:49467
Replace with: https://migrationproject.local

To use WP CLI in the terminal, I had to create an ssh user as WP CLI doesnt work with root.

  1. Add ssh user:
    adduser adrian
  2. Switch user to adrian
    sudo -su adrian
  3. Go to the the directory where the site’s wp files are ipwnstalled
    cd /www/kinsta/public/migrationproject
  4. Then finally, run search and replace:
    wp search-replace 'https://migrationproject.local:49467' 'https://migrationproject.local'

After that, my site already became accessible.

I hope it helps!

Hmm, the command ‘Adduser’ isn’t found when running it through the docker terminal. Is there something I’ve got to do before that point?

@devstagr Oh sorry, please try all lower case adduser .

omg I can’t believe I was that foolish! haha, got the user added now…

Although I have no idea what the port is as now DevKinsta refuses to start since you said to upgrade docker…