"turning on required windows features" Windows Subsystem for Linux (WSL) on Windows 10

Any news? :slight_smile:

Hi there,
got the same problem over here. Linux subsystem is already installed…
Is there an update on this?

1 Like

great that iam not alone with this problem.
So it is not my fault. It is a software bug in update.

Hi @Lolly . I’m sorry for the wait here. Could you also enable “Virtual Machine Platform” in the same dialog box from earlier?

Welcome @rafu! Let me know if enabling “Virtual Machine Platform” works for you as well.

Hey @michael ,
as i wrote the software was running until the update. The basic settings are therefore all correct and have not been changed. This can be excluded. There must be a bug in the update and in the installation file. can you provide me with the old one?

@michael ? Is is possible to send me the old installer ?

I would have liked to continue working with devkinsta, but it doesn’t make sense this way.
The old installation file would have really helped me a lot.

Hi @Lolly . I’m very sorry for the issues here. What version of Windows do you have? Could you review the requirements for WSL and let me know if your system meets those? I’m afraid we won’t be able to provide an older version here but hope we can get this solved for you on our latest!

Requirements are checked and everything passed.

Windows specifications:

I am experiencing the same issues.

1 Like

I am also experiencing this issue…

1 Like

and still no fix since one week.
I move back to flywheel.

I’m sorry for the trouble @Lolly . We’re working on a fix. I’ll update the thread here once we have something.

Same issue here, would love to have the previous version without that problem.

1 Like

Hi everyone. We released v1.0.3 today that resolves this issue. If you’re experiencing this issue, please re-download DevKinsta here as the auto-update may not work for you. Thank you so much and please do report if things are going well for you!

Sorry Michael, i have a stupid question for sur but, i had reinstalled DevKinsta and it seems to work but, i dont know how to reload my previous site on my local machine. Only option i got on the devKinsta window is “New Site Wordpress”, “Import from Kinsta” and “Personalised Site”. Could you help me please.

Happy to help! Could you confirm that the previous site on your local machine was also on DevKinsta? Was the other version perhaps uninstalled along with Docker prior to reinstalling the newer version? I’m sorry for the trouble here!

Hi @Catherine_Chang . Could you try the following as well?

Here’s an example of a site
Name: sitename
Original folder: DevKinsta/public/sitename
Domain: sitename.local
Database: sitename

  1. Find the old WordPress folder on your computer (DevKinsta/public/sitename)
  2. Rename the directory to → sitename_temp
  3. You should be able to see (sitename) in the Database Manager via localhost:15200. More info here too
  4. Create an sql dump / export through the Database Manager / Adminer
  5. Delete the old database (sitename)
  6. Create a brand new WordPress site on DevKinsta with the exact same name (sitename) → it creates a database which will be named sitename
  7. Copy all the files to the new site folder (DevKinsta/public/sitename) from temp folder (DevKinsta/public/sitename_temp)
  8. Drop all the tables from the new database and import the sql dump on Database Manager / Adminer.

Please let me know if you have any questions on this process!

1 Like

As this issue has now been resolved, I’ll be closing this thread now. If anyone is still experiencing issues, please create a new thread here. Apologies again for the issues!