Upgrade process Issues

The update process is confusing.

I downloaded the update, ran it, it says it will upgrade/repair existing install, but then it just uninstalls the existing installation and completes with no upgrade.
Have to run it again to reinstall new version, and it still shows the message “new version available”.

Hi @sonicviz, can you let me know what Operating System you are upgrading on. I’ll definitely bring this to our Developers’ attention.

Were you able to successfully upgrade? I’ve definitely noticed the “New Version Available” popup even after a successful upgrade.

Win 11, X64 pro.

Yes, I ran it again an reinstalled the latest.

Thanks for the confirmation @sonicviz!
I’ll have our Devs look into making this process more seamless.

Every single upgrade I go through, I experience the same thing (Windows 10, and 11, X64 pro)

  1. Download latest
  2. Install (only for me) - shows message that says it will upgrade/repair the existing install
  3. Run the installer.
  4. Launch DevKinsta, still says new version is available (it has been like this since the very first upgrade I ever tried)

Is there any location within the app that tells me which version is running?

Heya @Chevas :wave:

Is there any location within the app that tells me which version is running?

Regarding that question, on your Windows 10 machine, you can try to browse to this sub-folder/path for example:

C:\Users\ yourusername \AppData\Roaming\DevKinsta

inside that subfolder, there should be a config.json file. Please try to open it (with NotePad for example), and try to scroll down and find this section:

"__internal__": {
		"migrations": {
			"version": "2.9.0"

In the example above, it means the DevKinsta version is 2.9.0 . Hope that helps :slight_smile: