Can't install on Windows 11


Same issue reported here: Installation of DevKinsta on Windows 11

But the above ticket hasn’t been properly solved.

Basically, I find it impossible to install the app on Windows 11, not even with command prompt (the solution suggested in the other ticket).

And there’s no problem with the UAC config, I’ve been using this Windows installation for 1,5 years now, and never had any issue with a software installation - except DevKinsta.

What I see when checking the Security tab in the file’s Properties, is that there are four unknown account specified for the file in the Groups/Users section - which is pretty suspicious, not for Windows only, for my eyes as well.

My guess is that the installation problem is connected to these unknown accounts.

FYKI: these unknown accounts can not be removed, and their access levels can not be edited - they’re completely unaccessible even by the system admin, making the file config even more suspicious, no offence.

Thanks for investigating this further…

Hi there @WPDev_Studio :wave: and welcome to Kinsta Community!

Thank you for reporting this case to us.

I’ve installed DevKinsta (also re-installed for couple of times and been using it for several months) both on my main laptop (Linux Ubuntu 22.04 O/S) and also on my 2 other spare mini PCs based on Windows 11 Pro O/S, and so far have never experienced any issues (nor got the error related to that UAC thing) when installing on Windows 11 machines :thinking:

1 of my mini PC has this Windows 11 Pro version installed:

Edition Windows 11 Pro
Version 22H2
Installed on ‎15/‎05/‎2023
OS build 22621.2283
Experience Windows Feature Experience Pack 1000.22662.1000.0

And as I could see when checking the security tab in the DevKinsta.exe file’s properties just now, I didn’t see any additional unknown accounts (only shows the SYSTEM, Administrators and my user account) - so not quite sure where did those “Account Unknown” come from on your Windows.

Here’s the screenshot I took from my Windows 11 machine which I was able to install DevKinsta just fine.

and my “User Account Control Settings” has been set to this

It’s quite hard to see what’s causing this, and I couldn’t reproduce this error on my Windows 11 pro machine :confused: . Also so far none of our internal team and/or devs team have experienced/reported this issue either.

Perhaps try to turn off/disable Firewall (and/or any Anti-Virus you have installed if any) on your Windows 11, and retry. Also try to update your Window 11 with any updates available and once restart the PC/computer, you may want to try to install DevKinsta.


@Agus Thanks for the thorough testing on your end.

I also made a quick research regarding these unknown accounts, and all the Microsoft answer on all relevant threads is that these are just traces of old accounts that have been deleted.
Not a reassuring answer as I never deleted an account on my current machine, but that’s all I have.

Which leaves me with nothing :frowning: - I don’t have a clue why I can’t install the app on my Windows 11, so I’m afraid I’ll need to use another local server solution for the moment…

You’re most welcome @WPDev_Studio :bowing_man:

I see, yeah that’s really strange indeed and I’m not sure either why you have that “Account Unknown” thing (not really sure, if those were just left over data/user-accounts that were not removed completely and those might be created by the previous software you installed and uninstalled perhaps, just my guess :man_shrugging: )

I also tried to check on Google and found the following external resources/articles which suggested several fix methods for that error message (which could happen with other software as well):

This app has been blocked for your protection.
An administrator has blocked you from running this app publisher unknown.

They suggested same/similar methods as I could see, please kindly check and try/see if any of those methods provided may also help you to fix the issue in question, and so hopefully you will be able to install DevKinsta after that :crossed_fingers:

  1. Bypass “Administrator Blocked You From Running This App” in Windows 10

  2. App Blocked by System Administrator Windows

  3. How to Fix “This App Has Been Blocked by Your System Administrator” Error in Windows

  4. Top 8 Ways to Fix “This App Has Been Blocked for Your Protection” in Windows


1 Like

Wow! Huge thanks for taking a deeper look into this, @Agus !

Windows likes to play ugly games with its users these days - I’ll give these resources a thorough read, then, if nothing works, a complete reinstall is still an option.

Thanks again for the awesome support!!

You’re most welcome! :heart:

Alright, sure please take your time, and yeah hopefully any of those suggested methods may help (or otherwise a clean re-install of Windows 11 when necessary)!

best regards,

OMG OMG IT WORKS!!! :smiley:

Problem solved.

Soooo, if someone else with Windows 11 experiences the same issue, these are the steps that finally fixed the no-install problem:

  1. Go to Windows Security > Reputation-Based Protection, and disable EVERYTHING, except Phishing protection. THEN RESTART THE DEVICE.
  2. Right click over the DevKinsta.exe file, click Properties, and process the following updates:
    2.1. If there’s an UNBLOCK checkbox on the General tab, check it, and click Apply
    2.2. On the Compatibility tab, check the ‘Run this program as an administrator’ tab, and again: click Apply
    2.3. THAT’S NOT ENOUGH!!! In the same Security tab, click the ‘Change settings for all users’ button, and in the new popup that opens repeat the previous step: check the ‘Run this program as an administrator’ tab, and again: click Apply

And that’s it - after these updates, I could install the app, finally, a real miracle. BUT, the app install only completes after:

  • updating the linux kernel in command prompt with wsl --update
  • installing Docker
  • restarting the device again

Additionally, it might be worth creating a Docker account, but this one doesn’t seem to be a requirement.


@Agus, a last question: is there a Kinsta Dev documentation somewhere?

I mean, I have zero experience with Docker, and it would be great to know how do I access WP files, database, etc, from a Windows machine running Docker and a linux kernel.

Neverming, I foud your answer to this question at another thread


Awesome! I’m so happy to hear that you were finally able to sort it out and to install DevKinsta! :tada: :clap:

Thanks for sharing the steps taken from your end as well! that would be very useful for other users that may be experiencing similar issue in the future! :bowing_man:

Nice! glad that you found my answer at that another thread! :smiley:
Also, in case you would need to edit the WP files with software/editor (with Visual Studio Code for example) but it can’t open any of those local php files - you may need to map that WSL network path to the local drive first as I mentioned here

In order to access the local Database, you can use Adminer DB tool as shown in our doc here .

best regards,

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.