Uploading to Staging from Devkinsta stuck


so after i was able to pull the page I now cannot push the page to Staging. The process is stuck for hours now in the stage “Replacing linking to staging…”, see screenshot. I cannot even cancel the process, so i would need to kill DevK in the task manager. Knowing how much problems i had with the installation I am a bit hesitant.

What do you recommend me to do? Or how to fix it even if i stall it now?


Hey @Mikyboy :wave:,
It does look stuck if the % doesn’t increase :thinking: can you please send the last mainlog.log file so I can give it a look?
One of the reasons it might fail is the size of the DB but from what I read you should have solved this in the previous thread with @Agus .
By looking at the mainlog.log file we should tell where the search and replace process fails.


Ok thanks for the help, here the log file:

[attachment redacted]

Hi @Mikyboy

Can you advise your macOS version and whether this is being used on a corporate network, or this is a corporate laptop (with some MDM restrictions perhaps)?

Based on the log it seems like there’s a few other issues:

  • Can’t find /var/run/docker.sock

This is usually indicative that Docker is running in user-space e.g. in /Users/, which can be changed in Docker Desktop → Settings → Advanced → Allow the default Docker socket to be used (requires password)

  • Can’t create thumbnail

Looks like there’s some kind of local restriction on paths that either DevKinsta can write to or that your user can write to, maybe the result of an MDM? I’m seeing it fail to save a file to ~/Library/Application\ Support/DevKinsta/static/img/sites/ with ERR_CERT_AUTHORITY_INVALID (-202) errors.

That could also result maybe if DevKinsta/Docker was moved from Mac to Mac and e.g. the CA is no longer trusted.

  • API Timeout

Seems like this resulted in a DK0012 error, which means you might have to try different internet or attempt a VPN and see if that works, but your internet might be blocking the traffic to the Kinsta API

Let us know please if any of the above is helpful

OK well on Docker, not sure but how i see the Docker Socket is set as you recommended. And no this isnt a corporate laptop with restrictions, also no MDM (had to google it first :slight_smile: )

Thanks for that screenshot! Is there a way you can use a VPN to see whether your internet is being filtered, regarding the API timeouts.

Also, can you provide the output of the following command(s) in Terminal or iTerm:

security find-certificate -a -c 'space44.local'
security verify-cert -L -R offline -t -v https://space44.local

Trying to ascertain whether there’s an issue with your certificate in the macOS security store, and if so maybe can change the Top level domain in DevKinsta Site to something different, then change it back (it might require that you re-enter your password a few times to generate a new certificate).

Hey Alessandro i didnt even get to this point. Turning in circles here. Now for some reason it did not recognize the Docker installation again, although running in the background. I had this issue before. I uninstalled and reinstalled Docker. It recognizes it again but cannot download the docker image. I deleted all Docker containers, but still. So uninstall everything again and start from scratch? I mean this is really very buggy for me at least have to say, forgive me. Great support, but i dont know why the same things keep coming up over and over and its all so random.

Please let me know what you want me to do at this stage. Thanks

Hi Michael,

First of all, as I can see the last person replied to you was Zach instead of Alessandro :slight_smile:
Anyway, I’m not sure either if there were any recent actions (if any) from your end (or on your Mac computer) :thinking: as last time you were able to launch DevKinsta and were successfully import the space44 site (after you deleted that old database’s table issue on your live site, mentioned in the other thread).

To clarify, what’s the exact message you got now when you open/run DevKinsta? could you please send us the screenshot of DevKinsta that shows the error message on your Mac, so we can understand the current situation?

Also you may want to share the newest main.log file to us again, if we can see something else there that may help us to identify the issue.


OK got it Agus. But maybe check the other tickets of mine, the issue is identical. DevKinsta wont start, it seems to not recognize the installation. So i also cannot send you a main.log file. I have uninstalled and reinstalled Docker, didnt make the difference. Here a screenshot of the startscreen where its stuck.

Bildschirmfoto 2023-10-16 um 11.13.37

Hi @Mikyboy

Zach here!

Looks like we’ll need to do a full reset, which in order is:

  1. Exit DevKinsta (forcefully if needed)
  2. Stop all Docker containers
  3. Remove all Docker containers
  4. Remove all Docker VOLUMES
  5. Shutdown Docker Desktop
  6. Uninstall DevKinsta
  7. Uninstall Docker Desktop
  8. Remove the ~/Library/Application Support/DevKinsta/ folder
  9. Reboot
  10. Install Docker Desktop
  11. Install DevKinsta

Earlier, you mentioned doing a docker volume prune, which would only delete orphaned volumes, and not do a full reset. Once you’re at this point, go ahead and log in to DevKinsta with your MyKinsta credentials, sync your staging site to local, make your changes, and try a reupload.

Also, if you need to make backups and have a solution going forward for this, recommend looking at Philipp’s post here:

Best regards

Hey Zach, so i have done what you said. Uninstalled everything incl. Volumes and Containers, reinstalled. Its runing up again at least, but stuck at exactely the same point that was the initial problem, here the screenshot.

I cannot cancel the process, it says Cancellation will start after finishing the already started step in the progress. So i can only kill it again through the Task Manager, its been sitting in this status for hours now.

I really need to get this done now, we need to work on the Website. Please help here.

Thank you for your reply and update Michael :slight_smile:

Based on that screenshot you provided, yeah it seems it’s still “stuck” while replacing links to that staging site URL.

I still suspect that it might be due to too many records in the large table or something like that.

I also checked on your Staging server again, and noticed that there’s still a large DB table, about 2.3 GB : wp_wsal_metadata (with more than 11 million or rows in it - which is still large!)

First of all, make a backup (manual backup for this site in question, both for your local site on your computer and your staging site), and if you’re no longer using that table anymore (and it’s not being used by any of your site’s plugins/theme at all), then you may want to delete that large table in question, both on your local computer (use Adminer tool to delete/remove it completely) and also on your Staging (use phpMyAdmin tool to remove/delete it completely)

As I remember, in the other thread you mentioned that you’ve emptied that old table that’s no longer being used, and somehow it could not be deleted? :thinking:
This should be able to be deleted/removed using phpMyAdmin tool (select the table you would like to delete, then from the drop down menu “With selected:” choose “Drop” )

Once you’ve deleted that large table in question, please try to push your local site again to your Staging server and see if it will be completed just fine (not stuck in that replacing links process)?


Hi Agus, Staging is not up to date as i cannot push to Staging. You have to look at live. I cannot find the database there anymore

I have actually now deleted Staging and set it up new from live, so you can check Staging now for wrong tables again if you find it. Thanks for your help here.

Hey @Mikyboy :wave:
Inside your staging database, you have a table called wp_wsal_occurrences, this table is 1.5GB and contains over 5000 lines, 98% of your database size is made by that table.
I believe that this table, as the one Agus suggested before, was being used by a plugin that is no longer installed (activity log), if this is the case, I would recommend performing a new backup in Staging, deleting the table and retry the push to Kinsta.


Hi, we have deleted Staging and created it new by pulling the new environment from live. Thought this could be a work around, but not even that has worked. I was using https://staging-space44.kinsta.cloud/ but site doesnt load. So dont know where to start, but in that version of php i dont see that table you mention at all. But proof me wrong maybe i was too stupid there.

This is really critical by now so deperately looking to solve this.

Hey @Mikyboy, when you delete the staging environment and recreate it, sometimes the domain changes. https://staging-space44.kinsta.cloud/ is no longer the domain that your staging site uses. You can find the current domain in use by your staging by clicking the Domains tab in MyKinsta.
If you would like to avoid having the domain changed in the future, I would recommend making a backup of the live environment and then restoring that one to staging. By doing so your domain will not change and you will keep the backups made in the staging environment.

Anyway, I checked again and I do confirm that in the staging environment the table is still there. If you access phpMyAdmin (you can find the credentials inside the Info tab of your staging environment in MyKinsta), you can find the table by:

  1. Selecting the database at the left of the screen
  2. Sorting the view by size by clicking on the column title ‘Size’

You will then see the table that is 1.5GB big


Thanks Alessandro, well why the URL would change, i dont have to understand but well now i do. So i saw that now and yes works.

On the table i have now deleted the big table on Staging. I then tried to pull the Staging into Kinsta and i got the error on database dump again. On the second run it worked. But the database still shows 5.7gb on the import. Whats wrong there?

Hey Michael :wave:
I see that the database in your staging site is now less than 100MB, can you share a screenshot of what/where it shows 5.7GB?


Our developer had overwritten staging again with the old site aaaaaa and i have pulled the heavy site again locally. Now it wont start Docker again from Devkinsta. But interesting that is was able to now pull the 5.7 gB again. Whatever. I am deleting now Docker Volumes and Containers again and will delete the table on live and pull live now. Lets see if Devkinsta runs then. Keep you posted…